New update of RGT available (changelog attached)

Haven’t tested it yet.
Glad if this time they fixed the stutter linked to “many people on the voice channel” :slight_smile:

And usually, there are more features, non written, to discover. Last time there was a full new map :smiley:


I did the update today before riding. Wish I’d put it off…
As was true on the last update for me, it was a nightmare.

(BTW, I’m not aiming this @totolekoala at all, just responding to this thread because it seems appropriate to the Update issue.)

These updates haven’t gone smoothly in any way. The install file has to be downloaded to wherever we choose. Fine.
I download to a folder, but nothing happens.
I look in the folder and there’s the downloaded file, and another file that I can’t now remember because it isn’t there anymore. (I may have deleted it along with the downloaded install file because the whole thing was stalled, nothing happening, and I didn’t know if I should open/activate the install file or not because that other file was named something that showed it was RGT-related but suggested the download was “unverified” or something like that.)

I tried a 2nd time to use the UPDATE RGT button in the open, existing RGT app. That also failed to do anything different. Maybe that’s when I deleted the install files and the other new one, and I started again.
Once AGAIN, the downloaded install file did download, but sat there. Wasn’t going to do anything on its own, I could see.

I finally double-clicked it, hoping it would go cleanly from there, but it then reported that there was an existing instance of the application open that must be closed, (or maybe of the previous install files?? I’m just not sure.) It seems to me that this should either be automated with the install to close the old when needed, or at the least, should be pointed out to close the app once the update has been requested.
(I was ALSO getting notifications from Windows about these things because it wasn’t going to allow these EXE files to run if I didn’t give permission. I did give that.)

Finally, after closing RGT and letting it get cleared out, I either was able to click some OK button or something, or maybe had to RUN the EXE file again, I can’t remember which, and with much trepidation and very little confirmation from the install routine, I GUESS it got installed completely. It was a halting process with very little displayed information.

I THINK that then I had to go back and decide what method to use to START THE APP again. This time, unlike the last Update, there was still an RGT SHORTCUT on my Windows desktop. (Last time, it was wiped out and I had to recreate one and move to the desktop.)
I wasn’t sure if this shortcut would work correctly and point to the updated RGT.EXE file or not, but it apparently did, and the App opened up, had my information in there, and has worked properly. :face_with_raised_eyebrow:
Hopefully this will continue.

But I WISH this was not such a hassle to update a program/app!!
I already use RGT sparingly, much preferring SYSTM videos to any computer graphics visuals.

It really shouldn’t be too much to ask that Updates to the App(s) would be able to run with minimal interventions. I’m glad I finally got it done, but it was so far from straightforward that it cost a lot more time and uncertainty than it should.

I don’t mean to be unfair nor to slam anyone, but I hope future updates will run smoothly on their own, or at least provide some step by step tips if we are going to need to intervene.

1 Like

[I’m just a RGT user / organizer, not part of their team]

You’re not the only one that I saw struggle with the update, but most people report their frustration here or on the user group on FB : Can I suggest you copy-paste your message into a ticket, so that their support is aware of how non-intuitive the current update system is ? (the more we report, the more they are aware of it :sweat_smile: )


You would think that Wahoo could manage software updates in a better fashion. The amount of queries and failed updates that we have dealt with in our internal forums is ridiculous…

1 Like

+1 on all those comments… A COMPLETE NIGHTMARE!!

1 Like

I’ll look into doing this, good idea! Now I need to learn where and how to post a ticket. :slight_smile:

Am creating a ticket now with support. Let’s hope they recognize the problem and do something before any more fiascos occur.
Thanks for the suggestion, @totolekoala
and also for the confirmation that you also have had issues, @Casual and @ozmadman

1 Like