RGT, ANT+ and other devices


I wonder why I am not able to use my Garmin 500 head unit on ANT+ channels along with RGT
I have done this with TrainerRoad for many years

RGT does not recognize the sensors with ANT+
When I switch off the Garmin and do a restart everything is fine

Dongle, cadence and HR sensor are the same, Rally powermeter is new

Well yeah I do understand why sort of
But shouln’t it be possible to have them collect data side by side?
Or is it because you are returning data through the ANT+ to control smart trainers?

Thanks /Peter

@plykkegaard I haven’t done this but wouldn’t the connection be to the trainer and not RGT when you are dual recording?

ANT+ is not like BT. BT must be paired one-one with a device. If a BT sensor will pair with two devices, that’s two one-one pairings. ANT+ broadcasts data so it can be picked up by multiple devices. Sensors like speed, cadence, heart rate, etc can be received by any number of devices and I’ve done this for years with multiple devices. It’s been a while, but I think the same can be done even when the trainer is being controlled VIA ant+.

I have had the same experience with ANT+ earlier

I have a Garmin ANT+ dongle on my PC, a power meter (Garmin Rally) and a HR monitor on my bike, no smart trainer or anything else

With the trainer road app I have been able to use my Edge 500 head unit and the trainer road app at the same time

The RGT windows app does not detect any sensors if the Edge 500 is switched on
If I switch the unit off and restart the PC the sensors are fine on the RGT windows app
The same if I leave the unit off when I start a session

Not a big hazzle for me atm but sorry I am not subscribing to Wahoo X allthough I’d love to revisit Sufferfest

rgds /Peter

I’ve had issue in the past sometimes it was just a priority game try first turning rgt on and pair with sensors, then only turn on garmin unit and pair, that helped me, hope it helps you!

1 Like

Cool thanks, I’ll give it a try later today

Switching on the Edge 500 head unit after the RTG App has started does the trick