RGT Update Issues

I did the RGT Update earlier today. I went to schedule an event and when I opened RGT, it forced me to update AGAIN. The second update is taking a LONG time to do.

Anybody else have this issue or is it yet another RGT issue I get as a special gift?

UPDATE on my update. It finished the second update but it failed again to load. So now I have uninstalled completely and will do a fresh install.

I´m having just the same problem, always asking to update again…

It did work when I did a complete uninstall and loaded a full new install.

New post ride issue. When I go to My Account and select Strava as a Linked Account, RGT does NOT save that selection. So I can’t get my ride sent to Strava.

Got tricked as well :
That’s because the new version is not getting installed exactly on the same path.
Any link/shortcut/historical way to start would launch the “previous version”.

At least 2 ways to fix:

  • right click on the app → repair (it will find the new correct path to associate to the shortcut)
  • completely uninstall (this will delete the old pathway) and reinstall
1 Like

Yep I found this, delete the old shortcuts you had, find the new one (in mine it was in c drive program files wahoo fitness) on windows 10 run the app and then create a new shortcut. You should know by now, nothing is straight forward with Wahoo/RGT!!


Still NO Strava upload. No matter what I do, RGT won’t do it. I even disconnected the link and then re-connected it. I have never been a fan of RGT, but the distain has all been earned by the performance I get from it.

Have you tried revoking it on the Strava side as well as the RGT side and then reconnecting?

@jcolp not yet but good suggestion. The folks at support advised that I could go to my Ride History and manually send them to Strava, which worked fine. But they did not even address the fact that the app was not sending automatically.