Another possible Ant / dongle question: really dirty power data

Hello all! I’m not sure if this is a software or hardware issue. 2021-model-year Wahoo Kickr

Using a PC that does not have a bluetooth connection (not one I’ve ever seen - I built the PC desktop back in 2013 with some upgrades here and there since). I am using a CooSpo USB ANT+ Dongle with 6ft. Extension Cable.

I did a ramp test where it asked me to hold a heart rate for about 20 minutes, and I don’t think I’ve ever been that smooth with RPM for that long before - I did the absolute best I could do, holding 91 or 89 RPM even for amazing amounts of time, as needed, to go up or down with heart rate by two or three BPM to stay within range. Yet look at this power data. I saw it while riding jumping from the 140’s to over 200’s constantly, no matter how smoothly I pedaled.

I’ll buy whatever I can to get the system to smooth out. I know I am also experiencing the delays in it holding to power for up to 5 seconds after a segment is supposed to drop off, and that sounds like it’s the ANT.

If I don’t have Bluetooth on my desktop, can I add it somehow? Is there a direct-wired connection to the trainer that would be better?

(if that upload doesn’t work, here is the graph: )

Thank you!

Do you have any unecessary wifi repeaters/etc nearby? I have had these problems in the past and switching off such things really helped. See: Un-official LEVEL MODE MARCH MADNESS Challenge - #95 by leebo

There were comments/threads previous to this from where I got the idea. I use an ant+ dongle with a 6’ cable also (though after switching my repeater off I no longer use the cable and have the usb dongle plugged directly in to my laptop that is about 12 inches in front of my bars). Win10 machine but probably a similar vintage to yours, and a Kickr Core bought in Feb 2020.

Just a thought…


You can buy Wi-Fi / Bluetooth cards off Amazon for a very reasonable amount that’ll update your PC to take Bluetooth,

That’s what I did with the PC I made up for the garage and all seems good

This is the one I bought as I wanted a good reliable Wi-Fi the BT was a bonus

Ubit AX/AC WiFi 6 Card Dual Band 2974 Mbps AX200 PCIE Bluetooth WLAN Network WiFi Card with Bluetooth 5.0 | MU-MIMO| OFDMA| Ultra-Low Latency, Support WIN 10-64B

I’m sure there’s better options

I’ve just had a look at my last Half Monty test done in April my speed/cadence and heart rate all pretty much stay steady apart from a few spikes but my power is up and down for the entire 20 minutes, remember the 20 minute test isn’t measuring your power but your HR so to keep your bpm in a certain range you might well have to put more power through the pedals, I’d be interested to see if others have noticed this too.

Respectfully - I have to imagine it is measuring HR in context with power. Otherwise, what would it matter? It would solely be a test as to if someone can maintain X heart rate for 20 minutes, right?

You’ve got drop outs through the who work out - you can see the downward spikes at various points. However the jagged trace in the 20 minute test looks relatively normal. The trainer is reporting ERG mode smoothed power for the first part of the work out, but swaps to 1 or 3 second smoothing for level mode. Your power production almost certainly isn’t as smooth as you think it is. If you can turn off ERG mode power smoothing in the app you’ll see what’s really happening to your power during ERG mode, and it definitely isn’t a steady xxx watts.

1 Like

One end in to router and one end in to Kickr

So in my case I have a spare old router that I use purely as an access point m, which it self is attached to my router about 25m away by a long underfloor cable. That makes it easy to connect the kickr to my old AP. But I could also run that Ethernet cable all the way to the trainer if I wanted.

All depends on our own house setup I guess.


On one hand, you may be correct about power production, but on the other - as a smooth spinner, and specifically that post-ramp-test that day, I am positive that my power wasn’t swinging from 140 to 210 watts, to 160 and 190, all within seconds, while completely holding a specific RPM for long periods of time.

One second apart:

Four seconds apart, same RPM that I had been holding, and held, for quite a while:


Hi @Mambo

Without looking too much at the other responses; In the last month I switched away from my ANt+ only setup and have gone with dual ANT/Bluetooth devices (WAHOO branded strap, cadence, obviously trainer is also Wahoo) - I also purchased a small Bluetooth dongle receiver which I keep on a extension and sits under my bike (it’s a $15 tiny thing, you can do better.)

Since doing this I’ve eliminated nagging ANT+ issues (especially dropouts which is what i think is going on with you.)

ANT+ has always been an issue for me and frankly has shitty range and interference.

Out of interest, turn off erg smoothing and see what it looks like.

It may be that you gave multiple mini signal drops and that’s throwing the power readings out. Try turning your fans off and see if that alters it.

Finally got a Kickr Direct Connect. Hooked it up to the router via what I believe to be a new-in-package ethernet cable (it’s been so long since I’ve owned a wired phone, perhaps it’s a phone cord?) that I found in storage. I did the update at this point. I’ve restarted the router, the modem, and unplugged and plugged back in the trainer. At least I see ‘Direct Connect,’ but it specficially says ‘no network access.’ Anyone else have a little trouble getting it to recognize?

Hi @Mambo. Did you get this working? I’m considering getting a Direct Connect but there’s not much info out there from real users