Ant+ & TacX Neo not connecting in SYSTM app on MacOSX?!

Hi fellow Sufferlandrians,
it took me a while to figure out that each time when wanting to ride on my Tacx Neo 1st Gen trainer my MacBook Air wasn’t connecting via Ant+ using a dongle and an USB-C cable adapter. It worked fine with my old MacBook for years which featured a USB A/B port. The new ones only have USB-C ports thus making an adapter a necessary accessory.
With Bluetooth the trainer and the heart rate monitor connect without problems, the Ant+ method results in the MacBook not finding the trainer.

Before anyone suggests if another computer works, the answer is yes. My Lenovo ThinkPad connects to the Trainer effortlessly.

Anybody here who’s seen a similar phenomenon?

Thx for sharing!


1 Like

I use a MacBook Air which also has only the USB C ports so I require an adapter too for Ant+

I’ve got a Kickr though but haven’t had any problems connecting although I haven’t tried in a little while. If I ever do have connection issues, unplugging the cable from the MacBook and plugging back in usually resolves.

1 Like

What version of MacOS are you using? There have been some surprises with 12 and this may be one of them.

Hi there, I am running the most recent version of MacOS X. I reported earlier on a battery drainage problem here in the forum. The solution here was to turn of Bluetooth because it prevents the system from going to sleep once you close the laptop.

1 Like