Tacx neo connectivity issues

Hi can someone point me in the right direction please. I have a new Tacx Neo 2 trainer that I am trying to pair with the Systm app. I have the Garmin app down downloaded on my Laptop, run the update and put in my settings etc. if I go to a workout on Systm and go to settings as if I am ready to do the workout, the Systm app recognises the trainer on Bluetooth but none of the other settings i:e power, cadence or speed are registering at all. Sometimes it connects properly but takes about 10 minutes of switching things on and off. Didn’t get any of this with the Direto??

You need to turn off the Garmin/Tacx app othwrwise it’ll hijack your signal. Also spin the pedals to wake it up.

If that doesn’t help, let us know. I rarely had issues connecting with my Tacx Flux.

1 Like

Thanks, will try that this morning( spinning pedals had no effect) for my first session with the new trainer and let you know how I get on

1 Like

I have had the same issue with a Neo 2T connecting via Bluetooth.

Tried all sorts of troubleshooting. The only solution (and it’s only a bodge really) is to turn Bluetooth off and on again on the PC and remove and reconnect the trainer.

Sometimes only once, but sometimes takes another go and it all connects up fine.

Connection via ANT works fine but has a delay releasing the power and the end of an interval.

Everything works and connects flawlessly on the Mac so it seems some windows machines don’t play nicely with the app sometimes.

Hope this helps.


Thanks, yes exactly that. it shows up as connected on the settings on Systm as you load up a workout plus it is connected as the blue light is on, on the Neo but it takes a few on/offs to get it to display the other data. Used it for first time this morning and once up and running, what a great trainer compared to the Direto! smooth, quiet, responsive and just a very nice ride feel to it as well. Almost glad my Direto packed up just on a year old. Full marks to Elite though, they have agreed a full refund under warranty.

1 Like

Thanks, I had to fiddle around with a few on and off’s as mentioned in my comments to @DavM so I will see how it goes on future connections. cheers

Yep I looked back on some of my notes when I had rolling off resistance issues with the Flux. I did sometimes have to unplug it and then reconnect. Not as flawless as I thought

1 Like

I have a similar issue with the Tax Neo (first Generation). The strange thing is, that the app always displays it as connected when it is not. You can see that because none of the four symbols for power, control, RPM, and speed is shown. The only one thing that helps is to remove the trainer from the devices, plug off Bluetooth dongle, plug BT dongle in again and reconnect the trainer in the app. This always works for one workout. Whenever I run another workout or start the app the other day, I have to go through the process again

1 Like

I have something similar happen with my Saris Hammer smart trainer. I have the trainer connected to system via bluetooth. I boot up my computer, wake up the trainer, start the SYSTM app and the trainer only shows as a power sensor, not controllable, or having speed and cadence as possibilities. If I cycle the power on my trainer, it will reconnect and then all four possibilities are shown. I always use it for power, and as controllable. I use SYSTM virtual speed and a cadence sensor for those parameters. Have not had this happen in Zwift or Trainerroad.

1 Like