Bluetooth connection woes

Trying to connect the app via Bluetooth to the Neo 2t is becoming tiresome.

Connecting via ANT+ is seamless and fast, but am trying to circumvent the ERG release delay using BT instead.

When eventually connected, the delay is gone. But connecting in the 1st place via BT is frustrating.

The only workaround I have found that works (sometimes) is cycling BT on and off and restarting the app. Still takes a minute or 2 for the app to connect the trainer fully. IE, control power and read cadence.

Anyone any ideas what could be going on here?

I have unplugged ANT+ dongle, disabled it in the Tacx app and have nothing else connected via BT or ANT+.

Distance to the trainer is 2 feet from laptop.

Using win10 64 bit. All up to date.


1 Like

I have a similar issue. Using the Tacx Neo, but it does not seem to be a Tacx-related issue because I experienced the same lately when being on a KICKR Core. What I always do is to remove the connected trainer, then plug out and in again the BT dongle and then reconnect the trainer to the app. That almost always works. The problem is that I could not go this way as long as I was using the integrated BT of my laptop. I needed to shut that off in the windows hardware settings and switch to the external BT dongle. Still, it is not ideal though it works for me.

Yeah, tried that just now with a BT dongle with the same failures.

The app only sometimes sees the trainer.

Trainer connects instantly to my Tacx phone app and the Mac SYSTM app and the IOS SYSTM app all while using BT to control it. RGT the same, all instant connections, so pretty sure it is the windows SYSTM app at fault here.


1 Like

In the Tacx App on your phone connect to the Neo and under it’s settings, disable ant+

Then also try turning off your phone. I’m wondering if your phone and any head unit you may have lying around in sleep mode are trying to grab the trainer signal.

Then get your computer to forget the trainer. Power both off completely then back on. Sit on the bike and spin a few pedal rotations before starting the workout. Then try connect the trainer. I find I need to “wake up” my Tacx first, so always spin a bit before connecting. And also, when the workout starts, just keep pedalling for a few seconds, sometimes it just isn’t quite as instant connecting as we expect.

Hi DameLisa,

Yeah, tried all that… thanks for your help though.

Have opened a ticket with the minions for now.


1 Like

Thank you for your hints @DameLisa. Unfortunately, it does not work. I could not figure out where to disable ANT+ in the Tacx app (there is no such option in the trainer settings, or maybe I am missing something?), and actually, that would be less than ideal, especially when I want to link the trainer to RGT and SYSTM at the same time (which works quite well if I take the power readings only for RGT and let SYSTM control the resistance over BT).

Sir Holger,

In the Tacx app under trainer settings, then default settings there should be a wee slider to turn ANT+ profiles off. On IOS anyway, not sure about Android.


1 Like

I’m not sure if we are talking about the same app @DavM. I only have the Tacx Training app since the so-called utility app is no longer available.

Nevermind, @DavM and @DameLisa , I guess turning ANT+ is a feature for Tacx Neo2. I’m on the first gen Tacx Neo. So turning ANT+ off is not an option for me.

I have a Flux and I can disable it. Have done a screen shots for you, but also noting there are some wierd resistance drops that have been reported with some Tacx trainers on bluetooth in SYSTM.

Thanks again @DameLisa Now I know for sure that it’s not my fault but that the option is not there for my trainer.

1 Like

Dang was reallt hopinh that would help. Hopefully the next release sorts it.

1 Like