Bluetooth dropouts with System but not with TrainerRoad?

Hi Everyone,

I’m having bluetooth connection issues with System, but it works totally fine running TrainerRoad. Does anyone have any ideas?

I can see lots of discussion in the forum about issues with interference and/or with bluetooth headphones (which I use), but if this was the problem, wouldn’t it do it on Trainerroad too?

Specifically: my bluetooth mouse drops in and out OR my HRM drops in and out, making Wahoo System unusable for me. Everything seems to work fine until I connect the last bluetooth device (either mouse or headphones or HRM) and then the dropouts start.

My setup is:

HP Spectre x360 Convertible running an i7-1065G7
Kickr V5 (connected with bluetooth)
Assioma Duo power meter (connected with bluetooth)
Polar H10 HRM (connected with bluetooth)
Yamaha EP-E30 headphones (connected with bluetooth)
HP HSA-P007M mouse (connected with bluetooth)

I also have an Elemnt Bolt v2 on at the same time, connected directly to the power meter and HRM via ANT+, but not to the Kickr. The HR reads fine on the head unit, even when it’s dropped out on System.

1 Like

It seems to me that there are too many devices and signals around.

Anyway, I did had the same problem in the past but with Zwift and TrainerRoad and the issue was that one of them, I do not know which, was not releasing the bluetooth connection. The solution at that time was to force the shutdown of both programs from task administrator (Windows PC) and just restart the one I wanted to use.

Can you try that if you haven’t yet?


Thanks @Ricardo_G,

I would assume it was too many devices too, except that Trainerroad works fine with exactly the same setup.

I tried restarting the whole computer and then only loading up the one program (Wahoo System), so shouldn’t be a problem with something else releasing the BT. When that wouldn’t work I loaded up Trainerroad and it worked fine straight away without a reset. It’s also worth noting that the mouse or HRM (whichever one decides to be the issue on any given attempt) dropped in and out, rather than never connecting.

More often than not in my experience it is because one of the devices is still connected to an app that is using the BLE connection. I turn off apps in the background before using SYSTM as the wahoo app for checking firmware is normally connected to the KICKR, Climb, or headwind

1 Like

You might be spot on. Here’s what I recommend:
The old Microsoft reboot. Even if you are using a Mac.
Using Task Manager for Windows/Activity Monitor for Mac, go through and force close any application that even hints it is using Bluetooth. No YouTube as well (it is extremely stingy).
Start SYSTM and see if the device will connect AND disconnect repeatedly.

Stabbing Windows can also be effective … or make you feel better. Personally I was having Bluetooth weirdness for a bit in RGT until I determined that Windows had decided to revert the Bluetooth drivers to a version from a year ago. Updated again and life was good across all my apps. Same was happening to my video driver, that one was a battle over 3 days to get Windows to stop reverting it.

I’ve definitely been experiencing BT connection issues the last few times I’ve used the program on Windows 10. The app will be unable to connect to my trainer or HRM, which are still in the connected device list when I first start the new activity. The only way I can get them to connect again is to remove them from the connected device list, exit Systm, and then restart Systm and reconnect. This has been very reproduceable for me the last 2 weeks, I’ve had to do it at least 3-4 times now.

1 Like

So, it turns out I was wrong - TrainerRoad was having issues too. It was just a fluke that the BT worked the few times I was testing it with TrainerRoad, but not with Systm. Moving my computer slightly has fixed all the issues for TrainerRoad and Systm. Thanks for your comments and suggestions everyone - (I’ll keep the ‘stabbing windows’ one up my sleave!).

Hello. I am facing a very similar issue.
Setup: Tacx neo bike, windows 11 surface pro 7.
I connect to the Tacx neo bike using the surface pro internal bluetooth.
Trainerroad, RGT, Zwift connect to the Tacx bike without any problem.
With Systm (updated to last version) every day when I restart the app I have to go to devices, the Tacx neo bike is not showing all the functions available (see below screenshots).
I do disconnect tacx, search and connect it again.
Once it is connected no connection drops (with all the apps: TR, RGT, Zwift, Systm)
Before to disconnect:

Screenshot 2022-12-03 111936

Thanks, Luca

I continue my post (I can only add one picture per post).
Once I reconnect again, I see all the functions available:

Screenshot 2022-12-03 112141

Hi, I have the same problem. Every day when I want to have the training whith Systm (Win11) - Tacx neo bike, bluetooth, I need to remove the trainer, search for a trainer and connect it again (over BT). Otherwise it is not correctly recognized.
With the same setup (same pc, same Tacx), Trainerroad, RGT and Zwift connect to the Tacx immediately.
Maybe because Tacx and Wahoo are competitors on the same market, tacx is not fully supported?

It’s not the trainer. It may not even be SYSTM. I’ve recently experienced issues with my Garmin Dual when trying to run HRM tests. I follow Garmin’s directions to wet the strap, put it on, and neither EliteHRV nor Strava can connect. Go to Bluetooth on my 'Droid and remove it. Bring it back in and I cannot connect to it properly. Go through this process for about a half an hour (this is valuable time as I have to be somewhere most mornings now). Once it connects, I get varying results. It’s the HRM as I have to wet it several times to get it to work. However, I also suspect BTLE interference and device ‘theft’. If you are having issues connecting, make sure:

  1. The device can be seen by your receiver, cleanly.
  2. The device is not being used by any other program. This includes your neighbors who can see the device (BTLE has a reliability range of 12 feet, you would be amazed what exists in that range).
  3. That the device is actually transmitting data! For most devices this means spinning something or connecting something. For instance, my Quarq powermeter will show up on an ANT+ connection almost immediately. However, for BTLE I have to spin it for 30 or so seconds.
    Hope this helps.

Hello jmckenzie, thanks for your answer.
In fact I did try already all the steps you listed.
The point is that in the same environment/situation other softwares like RGT (which belongs to wahoo as well), TR, Zwift do connect to the TACX bike immediately. Systm not.
Was one of my try to spin the bike even before to start the Systm app, and keep spinning it until I start the training. Same result. The bike is either not recognized or as in my first screenshot, only one of the values availalbe (only being power controllable, not showing Power measurement, cadence, speed).
Thanks Luca

I would open a service support request as all of the Tacx devices are listed as supported to find out what is going on.