Forerunner 255 question

I use this watch but for the past few firmwares including betas it hasn’t been able to broadcast it’s HR to my laptop whilst doing a workout using our System software. I have the watch successfully linked as the HR sensor but it just refuses to broadcast the heart rate reading to the laptop screen.
Anyone else use this watch and have the same issue?

Have you power cycled the watch since the updates?

Tangentially related but I noticed my FR920XT stopped saving the GPS data to my runs after a recent update and a power cycle fixed the problem.

Oh…yes. I do a hard reset after every firmware update.

Don’t these watches broadcast as ANT?

Sometimes you may need to delete the sensor on your laptop and then go through the pairing process again. Bluetooth sometimes works like that (not sure on ANT)

No ant. I’ve deleted the sensor and repaired several times without success. I’m hoping someone else here uses this watch and has the same issue… Meaning it’s not just my unit which is faulty.

Can it successfully broadcast to another application other than SYSTM? RGT or even something non-Wahoo?

Good call to test… try connecting it to Systm on your phone. Both should be BT.
I’m using aFenix and it’s fine broadcasting. Can’t speak for the 255. If it’s a common issue, the Garmin forums will likely have it, but Systm finally picked up on Windows and phone from Garmin’s that broadcast

Tried with systm on the phone…nothing doing…I suspect it’s a firmware problem…Bluetooth connection has been faulty for the last two RC FW…but I was hopeful someone on here was experiencing the same issue. There are plenty of posts about the general Bluetooth pronlem on the FR 255 forum and I did actually post myself as to whether anyone there was experiencing a HR broadcast problem when I first encountered the issue…but got no reply.

Just tried it on my Forerunner 255, I’m on the latest Beta software build 14.08
Broadcasting to Strava on my iPhone worked
Broadcasting to RGT on my iPad worked
Broadcasting to Systm on my iPad worked

Strange…seems to work with Strava on my Sony android phone.