Kickr doesn’t register heart rate

I have a garmin HRM and a kickr that I use riding indoors on Zwift. Unfortunately a few months ago it stopped registering my heart rate. The HRM connects, but it just reads “0” while I’m riding.

This is both when I see it on Zwift and in the Wahoo app.

HRM works fine with other devices.

No other devices that the HRM is connected to is on, so that shouldn’t be the case.

Any ideas?

On Zwift:

R u sure the Garmin HRM has been added as a sensor in the Wahoo App?

Also, a new battery might help if it’s bee a while since you changed it.

Edit: also, welcome to the forums, Bo @Marienlyst

1 Like

Thanks :slight_smile:

Yes, I has been registered (I just tried unpairing and repairing before writing the post).

And battery seems fine (and it works fine on other devices)

@Marienlyst I had a similar issue with Zwift the other day with a Polar H10. It paired but wasn’t showing any metric. It was also paired with my watch and probably the Wahoo app. The H10 allows multiple connections but I tried unpairing from my watch and it then worked.

I would suggest submitting a support ticket with Wahoo related to the app and maybe do the same for Garmin and Zwift. If it is a bug somewhere it would be good to know so that they can correct it.