App update 6.23.0

Anyone else here having problems with the latest app update for Windows? 6.23.0

Everything was running fine on my dedicated Win10 (fully updated) Suf laptop in the gym until the latest update landed… the app will now not load when installed and will only open from the installer… when shutting the app down and restarting it, it hangs again with what to me looks like a memory leak???

When loading it from the installer file (ie, 1st run from installation) it opens 6 processes in Task Mgr, after closing it, and reopening, it only opens 4 processes and hangs. The missing processes from the list are the Wahoo fitness communicator and the ConsoleHost.exe.

I’ve spent all week with the minions trying to sort this and have even taken the nuclear option with a fresh install of Win10, different network with no change and now finding it a bit tedious TBH. Pretty standard replies from the minions… close all running processes and restart etc etc. No one wants to see any error logs? (if they exist)

All to no change in the app behaviour. This may seem like a rant and it is. After Suffering gloriously for 6 years with no software issues, the app pulls this stunt. Completely unusable (for me anyway)

I have rolled back to older versions of the app, but 6.23.0 will auto install at next launch and hang.

I can’t see how this would be a Windows problem anymore.

Any ideas from the collective mind??

My SUF is running fine. But I had some issues when my recent Windows updates changed my firewall permissions. Very annoying as it wasn’t obvious what the problem was. But once added as a trusted app no more problems. I had two Windows updates last week.

Thanks for the thoughts Dame Lisa, but yeah tried all that. Disabling all firewall and a/v software too also allowing the app as an exception. No change. :weary::weary:

:cry::cry: Hopefully gets sorted soon!!

Very odd.
Works fine for me on a laptop with enough junk on that frankly things should fail…

I assume the account you’re running from is a local admin on the device? Do you use wifi or wired network? Is that configured as public or private?

I’d suggest this is “one of those things”, because I have four separate (Windows) machines with the Sufferfest app on (don’t ask) and all of them are running fine on the latest version, despite being at different levels of Windows updated-ness themselves.

Alongside your network connection, what hardware are you running on?

Hi… yeah full admin access. Have tried using hotspot network too. Same result.

I have the app on macOS and iOS and they work fine on my home network. No fiddling required.

After a reboot of the windows machine, the app works fine. Close the app and restart it and it hangs again.

Have made firewall exceptions to all Sufferfest related applications in the installation folder. Squirrel etc. No change.

Running windows10 on a Sony Vaio intel i7 8gb ram. More than enough overhead.

Weird indeed.

“After a reboot of the windows machine, the app works fine. Close the app and restart it and it hangs again.” sounds very much like the process isn’t closing properly.
Try logging out and back in without restarting the machine, I’d be interested to know if that resolved it.


I fixed it.

So after a week of dead ends, even the minions were banging their heads.

However, after lengthy fault finding turns out all I needed to do was run the windows troubleshooting and choose compatibility mode for a earlier version of windows. Then delete all registry keys attached to Sufferfest. Then reinstall the app.

Seems something wasn’t agreeing with my build of windows. A fresh install of the os didn’t even fix it so am at a loss there.

But hey, it lives again!

Turns out you can’t actually leave.



Great news.

Just out of interest, when you say “A fresh install of the OS” do you mean you blanked the disk completely or installed a fresh copy over the old instance of Windows? (Because Windows does a very good job of leaving bits in place in the latter instance and it’s rarely the “clean” rebuild people anticipate)

Hi Jon. Yeah blitzed the whole disk. Totally nuclear option.

Was instructed to delete all Sufferfest items on the drive at the outset of this problem last week by the minions. So thought nothing to lose by blitzing the drive.

Thanks again. :+1:t2::+1:t2:

1 Like