Bkool, ANT+ trouble

Hi guys,
I recently have big troubles with my Bkool smart Pro 2 being recognized by Wahoo Systm.
I have a laptop on W10, I’m using it since 2-3 years (at first with sufferfest and then move on Wahoo).
I don’t have any problems with my cadence sensor but only with my bkool.
If i unplugged and replugged my ANT stick I have an errror (line102 about ant.cpp file, i don’t understand anything).

Moreover I downloaded Bkool app and I don’t have any problem to be associate it to my trainer…

Any ideas ??

Thanks !

1 Like

Hey @Fadel, welcome to the forums.

My only 2 cents of advice is to ensure you have all the windows updates for your PC, and that at minimum you reboot your computer and try again.

Otherwise, you might need to reach out to the minions for support

1 Like

Thaks for your answer !
I tried many things… reboot is one of them !
I contacted the minions, told me to let my trainer unconnected during 10mins, launch bkool see if there was no update and then go back to systm. But it didn’t change anything…
Waiting for their reply.
Hope I won’t have to go on Bkool being a sufferlandrian :wink:


Here’s hoping :pray:, since you can never leave :smiling_imp:

Is the error message coming from SYSTM? Or from Windows?

And, what specifically does it say? Can you take a screen shot?

1 Like

I see someone else reported this a couple years ago

Maybe @Thomas remembers what was done to resolve it?


I still get the same error message if I unplug and replug my ant+ Stick while Zwift and SYSTM are running at the same time.:
I just hit Ignore and have no other problems with it since I normally don’t re-plug my ANT+ stick.

As long as I use the correct order to start everything up and don’t unplug the ANT+ Stick I don’t get the error message.
Second: Zwift ANT+ with no power control

The error message is probably just a assertion used by SUF/SYSTM to “handle” a condition the programmers did not expect and did not want or expected to have to to put more time into it. They maybe thought nobody would want to unplug their ant+ dongle while running systm and wanted to ensure it is that way.

@Fadel I don’t really understand your problem. Your connection is unstable and you want to remedy this by re-plugging the ANT+ Stick?
I improved my ANT+ connection a lot with an 2m USB Cable. I put the ANT+ Stick on a cardboard box to elevate it slightly and ~25cm away from the antenna in the KICKR.
The wavelength of 2.4GHz is ~ 12,5 cm so you should have at least this distance to the antenna of the Bkool smart Pro 2. Also have at least this distance to any metallic objects.

On SYSTM I changed to BTLE since the connection is more stable and ERG switches are way faster. With ant+ i sometimes got 1-3 Second delays which were quite annoying.
Furthermore If I go to the loo the connection is not lost as fast and reconnecting is completely unproblematic. With ANT+ my TICKR sometimes had problems reconnecting.

Maybe Wahoo customer support is able to help or a USB cable remedies the problem.
If not please help us better understand your problem.


Thanks for your answer !
@Thomas : my problem is simple: I can not connect my trainer (bkool smart pro2) with Systm. I don’t know why because everything was ok before but now it’s not working at all.
Therefore I downloaded Bkool app and my trainer is recognized on bkool sofware…

We have exactly the same error message when replugging but I don’t think it has anything to do with the initial problem.

And i already have a 2m Usb cable :wink:

I’m wondering if a recent SYSTM update has somehow created this problem for you?

According to wahoo support, It worked on 7.71.0 version. But honestly I’m not able to tell you !

Back to basics : in what order do you set your trainer & app ?

r u asking me, or is that what support is asking u?

I’m asking you :wink:

It’s drivin me crazy… When I turn the BL on, my trainer is “discovered” but it’s useless because a bkool in bluetooth mode is not smart but only a sensor…

Ah, k. So, first I dont have a Bkool trainer, but here is my process.

I usually have SYSTM open (on my MacBook) and I often have the workout selected but have NOT hit the “Start Workout” button yet.

I then plug in my Kickr '18 and my Kickr Climb. I also have a Headwind fan and another fan I also turn on.

Then I will press the “Start Workout” button and make sure my sensors are all connected (green) and the settings are the way I want. Eg. Trainer control (erg or level), virtual speed, HRM connected and showing a reading. I usually airplay my MacBook via AppleTV to a larger screen and control my laptop from an app on my phone which I keep near my handlebars. Once on the bike, I make sure sound outputs have been correctly selected and working as desired (I usually wear bluetooth earbuds) as sometimes the sound output defaults to the AppleTV and I have to change it to direct to my earbuds.

I’ll usually then tap the Climb remote to allow SYSTM to control the gradient, then press the start button on the SYSTM video.

99.9/100 everything works perfectly.

On occasions where I do cadence builds, I use an Ant+ cadence sensor with a dongle attached to an extension cable so it can rest just under my cranks but otherwise the process is pretty much the same each time.

Thanks for your complete answer.
I did everything like you, still not working and waiting for wahoo support to help me…
I’m desperate…

1 Like