Stability and connection problems

Hi , Been using System for 3-4 years with some frustration in stability of connections. THe last 2 weeks was a new low point. I tried some of the new workouts that pop up when you sign in - On location, Suf (November) . So one day I can not get the heart rate monitor to connect, the next workout I cant get cadence ( but do get heart rate ) and today I could not get watts ! AND the video kept failing. Rebooted, checked internet connection…spent 25 minutes of my 90 minute time slot trying to debugg software and ultimatley switched to ‘14 vice grips’ which worked without issue. And no idea why.
Honestly - I find the software quite glitchy trying to connect. It takes too long, and I spend part of some warmups hanging sideways off my bike geting it to search for devices.
Cant debug an inconsitent problem !! (though open to suggestions)
(and just got an email from Zwift with an annual special …like all the videos on Sufferfest but really prefer how Zwift connects OUTSIDE the individual workouts)


So tried again this morning. Connection to November challenge Move workout gave me only the speed !! (not useful thing on a stationary bike in a basement…even Gunter would laugh). No watts, heartrate or cadence. Could not even save the non-wrokout. Moved on to Wahoo System Blender workout and everything connected .
So …whats up ??

It does sound rather strange that your sensors all show up in full on certain workouts.
Are you using ANT+ or BT?

I did have a similar issue previously but wasn’t as bad as yours, but I managed to get it sorted by:

  1. Removing all previously connected sensors
  2. Close and relaunch SYSTM

If that doesn’t solve the issue, perhaps try reinstalling the SYSTM?

1 Like

@loribairde That sounds to me like some other program or device is grabbing your sensors temporarily. Have you deleted and reinstalled SYSTM? Have you confirmed that all of your sensors have the latest firmware? Have you checked that the sensors are not connecting to other devices - eg. On my iPad or iPhone I go into settings and then Bluetooth and check whether there are any direct connections (probably similar on other OS) and disconnect them if that is the case.

Also reach out to Wahoo support for help.

Hi - BT connections. (I do have ANT possibiity but computer says Ant USB driver unavailable . I could persue that if you think it would make any difference…(but only for cadence in any case …?)
CHecked frimware. NO prompt for update.
Does not like phone being in the room. THat was last years conneciton issue ! CHecked PC and knocked off all the printers (though they are 3 floors up anyway and dont connect!) . Removed mouse, TV remote, and TV is off .
REinstalled and rebooted our house network.

I have not yet tried a System reinstall . Next project. Sigh…
Have put a note in with Wahoo support .

Open to other suggestions.
(COuld not get Watts with Tour de Suisse Women 1 race but could do Local Hero. GO figure .) Seems to like the older programs more…is there something particularly different in the newer workouts ??

The workouts are only videos and programmed targets inside the workout player. The connection to each workout is the same because they all use the same workout player. There’s no connection difference between workouts.

So if your sensors aren’t connecting, make sure they haven’t connected to any other nearby devices. If you’ve ever connected them to another bike computer, laptop, phone, iPad, etc, make sure they have been disconnected or those other devices turned off.

Sometimes my kickr won’t fully connect and I have to turn by PC BT off and back on to get it to fully connect. But if you can connect your sensors during one workout then you should connect during them all.

I use my Ant+ dongle connection for my HR and Cadence sensors and only use BT for my Kickr. Definitely make sure your Ant+ dongle is working correctly and available and use it too. See what combination of connections works best for your computer and sensors. You should be able to get them all connected consistently and stable. You can also ensure you don’t have too many other devices running in your pain cave because too many can cause a lot of interference, as well.

1 Like

BTLE is notorious for being fininky. You have to make absolutely sure nothing is connected to your devices. Your phone could be upstairs on the other side of the house and still be connected to various devices. It’s sad you can’t use ANT+ due to a lack of drivers as that would be the ultimate solution.

Ha…I went back to see last years (and the years before connection issue) and have feedback saying NOT to use ANT and just connect via bluetooth !
In any case, it worked today, all bluetooth. Go figure.
(So am I better now to just leave everything on, in the pain cave connected …? It still needs to connect everytime one starts a new workout …so perhaps better to turn bluetooth off on computer, turn on trainer, HR , start pedaling THEN turn bluetooth on then start workout ?? ?

It would be great if BLTE 4 supported multiple connections. It doesn’t. So my TICKR1 only has one connection. If it gets taken by my phone, I can’t connect on my Mac. ANT+ takes care of the multiple connection requirement so my devices can and do connect to multiple receivers.