Turn on Ant+ in Systm

I am working with a new laptop to run my cycling apps. I have Systm loaded and running fine. Added my mini keyboard with the provided Bluetooth dongle so I can do a few things while still on the bike. I plugged in the Ant+ dongle and downloaded the driver. However, Systm still shows Ant+ as turned off.

It’s likely something simple (I hope) but I can’t seem to find a way to turn it on. I did a search of the Wahoo site and the things I found don’t seem to help.

Any suggestions?

What brand Ant+ dongle did you buy?

I bought 3 different dongles when I set up my pc not quite 2 years ago. The one I had the best luck with is the Wahoo dongle.

When I plugged it in and started up SYSTM and started a workout, Ant+ was shown as ON. So I’m wondering if it’s an incompatibility issues. Unless you have a Wahoo dongle. Then I’m out of ideas.

Definitely not a Wahoo dongle but the one I have been using successfully for the past year on my old computer. I just moved it over.

I guess I will keep trying. :thinking:

1 Like

I know this is very basic troubleshooting but have you tried removing the dongle and putting it back in? Also, do you have an extension cord to bring the dongle closer to the bike?

Edit: and of course, making sure your computer has all the updates and that you have turned it off and on again (ie restart). This is Windows right?

1 Like

Thanks Sir Glen but tried all of the above other than bringing the dongle closer to the bike. As it is currently set up, it is max 3 feet from the bike. I have the computer on a table right in front of the bike.

Sad to say but nothing with Wahoo is easy. Most times you ultimately get there but sometimes the fight seems hardly worth the reward.


I have a pretty low frustration tolerance generally but when faced with an issue, my pathology won’t let me rest until it’s resolved.

So, fwiw, when I was using Ant+, one of the first things I did was buy an extension cable for the dongle so I could sit it just by the cranks. Never had a problem with Ant+ after that. Pretty cheap solution.

I generally use Bluetooth for my connections but still will swap over to an Ant+ cadence sensor when doing cadence builds.

I only use Ant+ for my HRM. I just figured that moving it from an older computer to a newer one, same operating system, it should work. Alas, not so much.

1 Like

Does the Ant+ signal from the HRM get recognized by another program on the new computer? Like RGT or Zwift? If so then the issue is likely SYSTM if not it’s probably the computer and you might need a different driver.

1 Like

Don’t use Zwift and have not tried RGT yet on this computer so this is the first app to give it a go. However, I finally got it to work. After trying everything I could think of and research all I could find, nothing seemed to work. I unplugged it and re-plugged it in, restarted everything etc. Finally I thought, let me start the ride but not actually start riding. Any+ was off. So before I started pedaling, I unplugged the dongle and plugged it back it. Voila, it turned on.

Not sure if I will need to do that every time but at least it worked. Hopefully next time I start a ride it will be on!?

1 Like

IDK if this pertains here, and my memory is a little fuzzy, but a year ago or so I had an issue where Win 10 was blocking ANT+ because of health privacy policy and I had to grant permission to allow it to be used. That cropped up a few time back then, but hasn’t repeated since.

FWIW, I was all ANT+ in Zwift and Trainerroad for many years with no issues. With SYSTM, I found trainer controlled lagged using ANT+ so switched the trainer to BT. Trainerroad and Zwift are still fine with ANT+.

1 Like

I found unplugging and plugging back in the dongle only works when closing the app and reopening it after plugging it back in.

Have found when dongle was off:not working, and app was open, plugging in the dongle had no affect. Had to close program for it to register.

1 Like

Thanks Sir Dan. My experience was exactly the opposite. The one constant with all this seems to be limited to it’s inconsistency.

For Systm itself I have only ever used BT. It’s my HRM that I have been using Ant+. Hopefully it will just work from now on but if all I need to do is que up the ride and re-insert the dongle, I can live with it I guess.

My use of trainers and sports monitors goes back long before BT was used for this purpose. It seems it’s only be the past 3-4 years where BT has become more prominent. My phones have supported ANT+ and so did the apps years ago. My phone still supports it (Galaxy S21) but no apps take advantage of that so via the phone, it’s now all BT/BTLE.


Here’s something that may sound dumb, but are the software portions of ANT+ installed? They aren’t default anymore for most operating systems. For Chromebook, there is NO application support for ANT+ due to a decision not to support it for Android.

1 Like

Yes I had to download and install the drivers. Microsoft does not auto load the drivers for Ant+ like most programs. Not sure what the issue was but I did manage to get it to work…at least once. Tonight I will see if it still ‘on’.

1 Like

Windows ANT+ driver allows single app connection only. Any chance that you have another app running in the background that “steals” ANT+ before SYSTM can take hold of it?

Unplugging ANT+ stick closes any active connection (obviously) then plugging it back again allows apps to grab it, SYSTM may win it (as in your recent case) or not, it is kind of race condition (unless foreground app has priority I am not aware of).

Amazingly, after a year, it happened again yesterday. I tried to start a workout and I got a Win 10 popup that said it was blocking sensor data and I had to select allow to get it to work. If I recall correctly, there were times a year ago where I didn’t see a popup and had to dig around to find where to enable sensor data…probably in device manager or something.

1 Like

None in my case. This is a dedicated laptop exclusively for riding. The only programs on it are Systm and RGT. I have yet to run an RGT video for unrelated reasons and have therefore never connected the bike nor the HRM to it at this point.

Last night it did connect properly so I am hoping/guessing that getting the initial connection done, it will connect properly moving forward.

1 Like

I have found I get an ANT+ OFF signal when doing back to back sessions, as in Save the first workout, go straight into Library, select Second workout and begin it, the ANT+ connection is never picked up.

Remedy is to unplug and insert dongle to retrieve ANT+ signal again. I needn’t have to close the program neither.

PITA if you ask me. Not sure if it is a bug, but it bugs me.

1 Like