Download dead

Just to check if it’s me or a general problem with the servers perhaps?
For the last 2 hours or so I’ve tried to start a workout. My internet is stable, everything seems to work, nevertheless when I try to start any workout, I get the message “Unable to play, try again later”.
Trying to download won’t even start.
That said, I did successfully download workouts with the SYSTM app already last week.
Any clue what might be the issue?

Working for me in the UK, not that that helps you. First thing - contact the minions if you haven’t already, always the best place to start for support

The old trick of turning it off and on again might help - log out, close app, open app, log in. If that doesn’t help, hit it with a hammer - is the only other suggestion I personally have other than contact the minions, sorry.

Hi @RenAn this probably isn’t it but you are running the latest software on both SYSTM 7.2.2 what whatever your operating system is, sometimes in the past this caused a blip on some of my cycling apps

Problem seems to go deeper. Logged out, cannot log in any more.
I contacted the minions.
Thanks for your support guys!


Yes, and that made it worse :wink:
Customer service also seems to have degraded. 14 hours now without any response. Would never have happened with the good old Sufferfest minions…:disappointed:

You do know that the minions haven’t changed, right? While you wait you could try logging in to the web app just to see if that works or if there’s an account problem. Link is


The minions might not have changed, but I suspect that either their working (and payment?) scheme might have seen some adaptations and/or they were totally not prepared, i.e. ramped up in minionpower, for the flood of issues coming along with the new app.
I did already log in to the website, successfully. It seems to be clearly an app issue.

Other question to see if these problems are related: Is it generally not possible any longer to download videos with the SUF app?
If that’s the case, the two problems I’m facing have nothing to do with each other and the SUF problem is actually a feature, not a bug. If that’s not the case, then my problem extends beyond the SYSTM app and affects also the SUF app. So in this case it seems to be on a higher layer

That’s a pretty massive assumption. Is there a body if evidence that suggest either of those things are true?

Anyway, back to your issue. What message are you getting when you ‘can’t log in’. There are a few people in this forum who may be able to advise so if there’s a way you could note the o/s you’re on, app version, error message then can try and provide as much help as we can as a community.

Picking up on something you infer in your last post - are you using the new SYSTM platform or the old SUF app?


Hi Martin,

okay, first, let’s be open here, I’m a tad frustrated with all the changes going on and the partial disappearance of my beloved Sufferlandria. Hence the tone in my previous message. It is not my intention to accuse anybody personally here, the minions have done an outstanding job every time I needed their help! I do genuinely believe though, that people were not prepared for the amount of queries coming in together with the app change and all that.
A response time of 24h is not awful, especially when some of these hours fall on a Sunday. On the other hand I have never experienced such a “long” response time here before, and especially in times where it was vlear a lot of things would not work smoothly, I hoped for something better.
All that said, if anybody felt personally attacked by my post, please accept my apologies! That was never my intention! We can blame my impolite German background, shall we? :wink:

Now back to my issue:
I’m currently running both, the SUF and SYSTM on my… ehm… system… :wink:
I understood that would not be a problem, and during the first 2 days IT WAS NOT a problem! Just stating this in capital letters to make it clear that the setup worked already.
My intention was to keep the SUF app available as a fallback for a couple of weeks, until I can be sure the SYSTM runs stable.

I’m running on a Mac Book Air, OS X Version 10.11.6.
I do have sufficient HD memory available.

App version? Hard to say… I cannot get beyond the log in screen. Let’s just say, the latest. I re-downloaded and re-installed yesterday, as part of troubleshooting

Error message simply says “Whoops, looks like something went wrong.” Very useful. Excuse my sarcasm…
Trying to reset my password results in “We were unable to process your password reset request. Please try again.”

On the SUF app I am still logged in. Any download I try to start simply sits at 0% forever. The play button for all videos I have not downloaded is dead. No reaction whatsoever. Playing previously downloaded videos is possible.

Let me know if I can provide any other useful information.

Many thanks for trying to support me here @all!


Ok, so you can’t login on SYSTM (the “oops, something went wrong” message)

And SUF won’t play videos (and those are downloaded).

Ok, I’m off to fire up a MacBook……


((Just noticed one thing - but it is probably/possibly irrelevant as you’ve been using SYSTM already - that’s an old Mac o/s (I updated my old MacBook at the weekend so I was above 10.15 and it jumped all the way to 11.6 - so I hadn’t updated it in years obviously)
As I say, that might not be related whatsoever but just flagging in case useful to you. The minimum o/s’s provided were:

  • **iPhone/iPad: iOS 14. *** If your apps are set to auto-update, the app will do so automatically.
  • **MacOS: Catalina 10.15. *** You’ll need to download the new app. We’ll provide you with a link on the day. You can delete the old app once you’ve got the new one.
  • **Windows Computers: Windows 10 (v1903). *** You’ll need to download the new app. We’ll provide you with a link on the day. You can delete the old app once you’ve got the new one.
  • Android: Android 9. You’ll be able to download directly from the Google Play store.))

Cheers Martin, highly appreciated!

1 Like

Next question.

Is your MacBook an Intel based one or an Apple Silicon one?

Mine is an older Intel chip MacBook. And it’s playing videos on the old SUF app ok

And version 7.2.2 of SYSTM is also playing videos fine too.

So that will help the minions track this down hopefully.

Can you double check you have the right Mac install? (As it’s been working previously that shouldn’t be an issue but good to rule things out. Might even be worth a delete and re-install just to make doubly sure). Downloads for the two different chipsets are here:

Thanks again for all your efforts!
It’s an Intel based and I double and triple checked I’d download the correct version when re-installing yesterday.
I checked the install file, and I can confirm it says 7.2.2…

It’s not a video playing issue. As I said, I AM able to play videos on the SUF, as long as I had downloaded them before.

The whole thing looks like a connection problem. I can do all the things I could usually do when offline, i.e. play downloaded video, browse the menus in the SUF app…

I just cannot…
… log in with the SYSTM app
… download any videos
… play any videos I have stored locally already

Oh and before someone asks: I’m using this very MacBook to generate these posts here, so yes, I AM online :wink:

That’s hopefully helpful for when the minions are working out what the issue is here as it rules out a bunch of stuff. Realistically, without being a minion with access o your permissions, I’m probably at my limit now. Unless anyone else in the community has some clever ideas.

Seems quite odd on the face of it. Glad you still have access to content in the old App - that’s good to hear (albeit only ones you’ve already got downloaded).

In testing days I occasionally had an “oops, something went wrong” message but can’t for the life of me remember if I ever got to the bottom of it. Hopefully it’s some sort of permissions thing that the minions can sort for you

Hi. I didn’t see a reply so just to check - have you updated to the latest MacOS and tried that? (for clarity that might be why you have as 10.11.6 mob is the same as what i see as 11.6, just not 100% sure - Big Sur is it’s nickname on my machine)

I had no issues on the latest version and someone else has resolved their issues with updating the OS as well

I’m not sure if this might help or not probably not but when the Suff changed to SYSTM last week I couldn’t log in to SYSTM with my Suff password it just wouldn’t work but luckily I was able to reset my Wahoo password as I had a Kickr about 4 years ago so reset it and that worked, I’m just wondering if your Suff password isn’t working on Wahoo and when you try to reset the password it can’t. Do you @RenAn already have an account with Wahooi don’t mean the Suff one ? Wonder if you maybe need to create a Wahoo account in case that’s why your receiving the password problem.

1 Like

I’m actually more confused now because @RenAn if your able to post on the forum obviously your Suff or Wahoo password works fine to get on the forum so that is a weird one don’t understand that myself either if you can log into the forum but not into the SYSTM app as it should be the same name and password for both :thinking::thinking::thinking:

Are you logged into SUF already and then trying to log into SYSTM? What happens if you log out of SUF?
Someone else in this forum had a similar issue. They uninstalled both SUF and SYSTM. Reinstalled SYSTM only and no more problems. Worth a shot although I appreciate you wanted to keep the original app installed for a while. Any chance you have another laptop or device kicking around that you could try?

1 Like

Thanks all!
I was pretty busy this afternoon, so didn’t follow this thread.
Thanks for all the ideas. I’m gonna have dinner now and then get back to troubleshooting. Also got in touch with the minions in the meantime.

I’ll let you know if I have any success.

1 Like