App does not refresh on start (mobile)

When I launch the app on either my iPhone or iPad it starts with the previous day selected and shows no workouts completed as if it never happened. I have to do a hard restart in order to get the app to recognize it’s a day later and I did, indeed, complete the workouts for the previous day. This has been happening since the initial launch of Systm and happens every time.

1 Like

Oh that sucks and is def the wrong kind of suffering.

Few things to try:

  • log out, log back in
  • complete uninstall and reinstall of the app

If neither of these work, you should absolutely reach out directly to the minions (I think they’ve had too many donuts so might have had a day or so off over the heIIidays but are likely back to bizness)

1 Like

Also, what version of iOS are you on? There is a minimum version you have to use in order for the app to function properly.

Thanks Glen. I tried both and I’m still getting the issue so I submitted a request.

1 Like

Brand new iPhone 13 Pro, newest iOS.

Ok. Submitting a ticket at this time is the best thing to do. Your issue shouldn’t be happening with this combination.

The minions are usually pretty awesome about responding and their service is exceptional. Be patient though as I imagine at this time of year, like anyone working in the fitness/health industry, things must be pretty intense. Happy New Year!!

I started getting the same issue after New Years. No saved record of cycling, strength, or yoga workouts. No change when I logged out/logged in. Deleting and re-loading the app seems to have fixed it.

I had the exact same issue this morning! Super annoying and I lost my ride and yoga workout. It said it saved but then it didn’t update or sync and it looked like it wasn’t completed. Also iOS with the latest software.