How to view Glucose levels with Wahoo Elemnt?

Has anyone had any luck setting this up with an ELEMNT ROAM v2, by chance?

Hi, I have not been able to make it work with my iphone + dexcomG6 + wahoo elemnt.

Thx for the reply and sorry to hear that! I will probably look into switching to Garmin for Dexcom G6 integration or possibly switching to Supersapiens but I don’t know much about their tech yet.

1 Like

LIBRE 3 is the base device.

I tried Garmin 840 with dexcom g6 and iphone. It worked, at best sporadically, so I returned the Garmin.

When installed the xDrip+ app on Elemnt Bolt V1, can I still receive the BG during or after the ride on my phone? I am using AAPS which uses xDrip+ to get the BG data and adjust my insulin level.

I’ve finally updated my phone to transfer xdrip+ data to my Wahoo Bolt V1. Now, I’m receiving blood glucose (BG) readings. I’ve set the xdrip+ channel to 1 for the Bolt and 2 for the phone. It seems both devices can receive the BG simultaneously, but when I have both devices next to each other the bolt does not update. Even though the channels are different. Does the channel setup transfer to the bolt?

After being delighted to see my blood glucose (BG) readings on my Wahoo ELEMNT Bolt, I’m disappointed today because I’m only receiving ‘Examining’, ‘Sleeping’ or ‘Power Connect,’ but no actual results. I’ve reinstalled from xDrip several times, but with no success.

After changing the channel to 1 on one phone and channel 2 on the other phone, I messed up my phone with AAPS. I wanted to test it to ensure it was working and hopefully using the same channels as the Wahoo (1) and the phone (2). Unfortunately, the Wahoo still isn’t receiving any BG readings. Any hints or help would be highly appreciated.

Hi guys, I´m a new member of a wahoo elemnt roam v1 device! I read so many articles and I saw also the you tube video of “how to connect the wahoo with your mobile phone”, but it´s not working! I can´t connect my mobile phone with the wahoo elemnt roam v1! The otg connection is not working! I tried different adapters and cabels… but it´s not working! I can reaload the device but I can´t start the command: “start usb configuration!” I have the xdrip+ software installed on my phone and it´s working! I use the software to transfer my glucose levels to my garmin! Am I too stupid? What do I wrong? It would be great if somebody of you could help me! Because this would be my personal “life changer”.

It’s unfortunate to hear that your experience with the Garmin 840 and Dexcom G6 setup didn’t meet your expectations, especially if it was working sporadically.

1 Like

I’d blame the Dexcom for the disconnect issues. I follow several T1D folks and they complained about this issue. Fortunately, the software they use can run several attempts to connect and it pings the CGM about every five minutes.

you need a data cable to transfer the data to your roam

Hi Wickiman, thanks for your reply! I tried so many different otg cables and adaptors, but none of them didn´t work! I got a storage drive connection throught the Wahoo and my mobile phone but that was it! The command: “start usb configuration” didn´t work! Do I have to make any settings on the wahoo or in the xdrip+ software?

Thanks in advance for your help!

@Andre2903 In the video the OTG adapter is connected to the wahoo, but in my case I needed to connect it to my phone and the data cable to the wahoo. Then it worked. First I saw the content of my wahoo and than I authorized the transfer to my wahoo. I also attached first a USB to my phone to make sure it is working.
Not sure if it is your case as well, but my phone does not really allow OTG even all test apps tell me. Do you see the content of your wahoo? I updated an old google nexus 5 with lineageos to make it work. My Xiaomi Redmi Note 11 does not work at all I believe.

Thanks for your help! I tried both ways->otg adapter to phone and the other way round! I can have access to my wahoo through my mobile phone! This is working! I see all the folders of my wahoo through my mobile phone! But if I will start the command in the xdrip software “start usb configuration” nothing is working! The connection status is not active! What do I worong? Could you send me a detailed protocol how to set up the xdrip software for the upload? Maybe there is something different! I also checked my mobile phone if it´s otg able and yes, it’s otg able! Damm! It would be great if you could help me! Thanks in advance! I attached ONE


file to my text! Maybe this will help :wink:

Sorry for the late answer, was on vacation.
Since you can see your wahoo elemnt bolt, you should be able to transfer the data from xdrip+. Your bolt is V1 and you have authorized it? You did everything the same way as in the video?
If yes, I have no idea why it should not work.

Can I also do the transfer manually? Which data has to be transfered? Xdrip+ is not aking for permission! Yes, I have a V1 elemnt roam! Do I have to make any settings in the xdrip+ software before? I connected my garmin watch with the xdrip software and this is working! Damm…

manual transfer is not possible as far as I know. I just tried it again this weekend and I needed to authorize xdrip+ to connect to wahoo elemnt bolt. nevertheless there was no connection or whatsoever to see my BG.
You said you connected your garmin watch with xdrip. Did you use the CGM TIR FACE? This is what I will do now. Xdrip shares the BG with my old watch without internet. Hope this helps.

I use the xDrip+ Sport App from Andreas May, because my Garmin (235) is not the newest :wink: It would be more comfortable to have the glucose level on my Wahoo! But I can also watch the values on my watch! Better than nothing :wink: Thanks for your help and the nice communication!