I'm new to Wahoo system ..they support really suck ...can anyone help please ...Using wahoo system on Mac M1 ...but no RPM/HR or power showing...On my iPhone wahoo fitness only HR & speed showing?

I’m new to Wahoo system …they support really sucks…can you help please …using Wahoo system on Mac M1…but no HR/RPM or power showing…on my iPhone wahoo fitness HR/RPM are showing >…Help please …

1 Like

Firstly, hi and welcome to the forum.

Secondly, I suspect your iPhone is grabbing the signal from your heart rate monitor and cadence sensor. There are limitations with Bluetooth and how many devices your sensors can connect to.

Try turning off your iPhone’s Bluetooth and try again. I’d recommend rebooting your Mac as well. Note I’m a PC user not a Mac user so can’t comment on your specific Mac being a supported device. @Glen.Coutts do you know?

Support is actually usually pretty good, but they’re also not awake 24 hours a day. Am sure someone will get in touch with you shortly but hopefully the above fix works.

1 Like

Dame Lisa is right. If you’re connecting SYSTM to your Mac you can’t also have your sensors connected to your phone at the same time. So, either turn Bluetooth off on your phone or force close whatever phone app you’re using that is showing the HR and RPM (I think you said the wahoo fitness app). Bluetooth is generally limited to connect to one device at a time.

As for power showing on SYSTM, have you connected your power device?

There’s a bunch of support articles that should get you sorted if the minions (Wahoo support) haven’t gotten back to you but rest assured they will.

In the meantime you can check out this page for some guidance.


Edit: also, welcome!

1 Like

Thank you guys …very much

1 Like

Happy to help (other people to suffer :wink: ) Check back in and let us know how you make out.

Thank you very much

1 Like

Glen first thank you …I did all those thing nothing works …I confess I’m newby …I used Zwift for year (so easy to use)…then I got fooled by YouTubers wahoo paid lobbyist on great wahoo system is …yeah its one of those mistake ,all my morning lady reading all the forum trying everything …& they support never got back to me. NB# bluethoo on
but Ant+ off & couldn’t turn it on … But thanks Glen …I like simple thing so better get back to zwift…

1 Like

There’s a bit of a learning curve @Yitzhak1 but it’s worth it. Are you saying you’re trying to connect via Ant+ but can’t? What kind of trainer are you using?

Also, it’s important that when you download SYSTM that you download the right one for your MacBook. There are 2 versions. An Apple Silicon (M1) version and an Intel version. Is it possible you installed the wrong one?

If you got the wrong one, you should uninstall it and grab the right one here.

I’ve tried most of the training apps out there and continue to use Zwift a bit but I mostly use SYSTM cuz the workouts on Zwift just bore me to death. Once you get the hang of the setup it’s pretty straightforward, though, as you can see, not as straightforward as it could be. I’d also hang on a bit for the minions to get back to you. I’ve always been 100% satisfied with their service. To be totally honest, I’ve never had better service from any company in any industry than the service and support from Wahoo (and the Sufferfest before them).

1 Like

I’m using wahoo last smart kickr 2020…it was working fine with Zwift …As you said maybe it needs a lot learning what I’m not patient for …I like thing simple on my 70 s tired of learning … Toronto is freezing cold , can bike outside …we are on lockdown again so the Gym is closed …I thought Wahoo system will be be helpful … I 'm going to try again again …I’m stuck for a month I already paid it , so I’ll keep it till the last 4 days & cancel it …Zwift now is offering one month free if I go back to compensate the what I pay for WS…
kind regards

1 Like

First: What protocol are you trying to use? Macs do NOT support ANT+ out of the box. Never have, never will. You have to get a USB ‘dongle’ with a USB-C connector to make this work.
Second: Unless the sending device supports the newest BlueTooth Low Power protocol, which was released this year, you get one device connection to one device. I.E. if you have BT connected to your phone, it owns the connection until whatever application is using it is completely shut down (this means force closing the app on Android, just simply “skipping” it doesn’t always work.
Third: you can get SYSTM for all of your devices. I have it installed on a Mac and a 'Droid device and I have ONE subscription. You don’t have to ‘buy’ Apple’s subscription if you already have one. This is my preferred method of using SYSTM.

I ‘m not trying to use Ant just saying as it look in picture it’s off…Bluetooth is on …I turn of Bluetooth on my others gadgets iPhone/iPad .I even unplug Apple TV. .as I use to use it with Zwift but still nothing showing ,another thing I didn’t see where to check if ERG is on or off …I did little ride this morning …it does look that ERG is on …

Yes Glen I download the right application …my Mac is M1 …& that what I download .

Did you click the Add Devices button on the screen you show in the picture? If not, click it! The sensors don’t show up unless you add them!


There’s a quick start guide that includes instructions for connecting sensors. Worth a look if you’ve not seen it. From your screenshot it does look like you haven’t added any devices. https://support.wahoofitness.com/hc/en-us/articles/4405908390674-A-Quick-Start-Guide-to-the-SYSTM-App

Yes I did it add my kickr ,& my HR …but not showing on the workout

but the screen shot you’ve taken shows no devices have been added. Like this. This is a shot of mine when I am not near my devices. It shows the list of devices I usually connect.

You can only add devices when you start a workout. You do that by clicking on the “Add Devices” button that you were showing on the screen shot you provided.

Edit: once you have your Kickr connected, it will show that it is in ERG mode (that is the default mode).


If you click the Add Devices button and NO devices appear, click on System Preferences → Bluetooth and see if they show up there. If they do, something else has paired with them. If you have the Wahoo App installed, open it and UNPAIR the KICKR and TICKR. Then go back to SYSTM and see if they are there. For some strange reason, Bluetooth apps on the same device keep the connection even when shutdown. This is a common issue with Garmin Connect and SYSTM for Garmin devices. You have to unpair on the Garmin app or SYSTM (and the old Sufferfest app) will not ‘see’ them.


I’m in Toronto too. Had to dig two cars out of the snow today after the plow buried them.

Sorry to hear you’re having difficulties - I’m finding connecting to Systm is just as easy as connecting to Zwift. I can even connect to both Systm and Zwift at the same time…

I’m running on a Win 10 PC though.

Pls persevere - I think you’ll find SYSTM is worth it once you get your issues worked out.

1 Like