RPM Speed & Cadence sensors with Zwift setup

Hello everyone. New here and looking for some help please.

I bought a Wahoo RPM Speed & Cadence sensors in order to use them on my roller trainer. The goal is to use the sensors on the roller trainer with Zwift app. Wahoo mobile app recognizes the sensors after I followed Wahoo instructions. However, I am unable to get Zwift to recognize the sensors. Is there anyone out there who has been able to successfully pair Wahoo sensors with Zwift? If yes, any tips and tricks please?

Thank you

Hey @orbatron, cool name. Also, welcome to the forums.

In my experience, many sensors only allow for one Bluetooth connection, which is what I will assume you are using for Zwift. So, if you have the Wahoo app open and it has “grabbed” the connection, then Zwift won’t be able to.

Try force closing the wahoo app, and see if you can then connect to Zwift.

It also doesnt hurt to turn bluetooth off, then back on, on whatever device you are using.

1 Like

What @Glen.Coutts said.

I use both TickrX and RPM Cadence sensors. And in the past I used the RPM Speed sensor too. All on Zwift and SYSTM and others.

Make sure they aren’t already being grabbed by another app. That’s usually the culprit.

1 Like

So no other app besides Wahoo app is grabbing the sensors. The issue is that Zwift is looking for devices but not finding them even though the lights on the sensors are flashing. That’s the issue and I can’t seem to find a solution.

2 Likes

If the Wahoo App has grabbed them, Zwift can’t. It’s a limitation of the way Wahoo initially installed BTLE. You’ll have to get the Wahoo App to release the connection. Usually shutting down the App will work, but I had to shut down my Bluetooth to finally get the connection to close.

1 Like

I’ve tried that. Not sure if I got a dud from Wahoo or not. I keep shaking the speed sensor and the light won’t go on. Frustrating.

So, I am not sure we are being clear (which is 100% possible :stuck_out_tongue: ) , or if we are clearly not understanding your responses. Or maybe both.

But…you need to fully, force close the wahoo app. then, and only then, will the sensors be available for Zwift or anything else.

What hardware are you using to Zwift? Is it a separate thing from where you have the wahoo app or are they both on your mobile device? If they are separate, then try turning off bluetooth on your mobile device and see if the sensors connect to Zwift then on the other device. Also, are you able to connect other bluetooth things to the device you are using for Zwift (like a pair of headphones, or maybe a hear rate monitor). If not, it could be a problem with your device. Some PCs need an extra bluetooth dongle for the bluetooth to work properly.

Purpose: Use my bike on a Feedback Sports Omnium Over-Drive Portable Bike Trainer. When it rains my group uses Zwift to bike from home. I don’t care for extremely accurate stats I can get from a power meter, thus I Wahoo Speed and Cadence sensors. I just want to virtually ride with friends who all use Zwift.

Device: Connecting to an iPad that is used at home as a media consumption device. I do have headphones connected via Bluetooth so I know that part works. Also Wahoo app was able to find the sensors, so I know Bluetooth works fine.

I have deleted the Wahoo app from the iPad completely, rebooted the iPad, turned Bluetooth off and on. Zwift keeps saying it’s searching for a device but no cigar.

I guess I have to call Wahoo, and maybe Zwift support. :confused:

Thanks for the extra info. The more detail the better the chance of finding a solution. You might need to contact support from wahoo or Zwift. It couldn’t hurt.

One more thing, is it possible that your sensors are connected to iPadOS in the Bluetooth settings there? If they are then you’ll need to go to the iPadOS settings and forget them. Then try pairing to Zwift one more time.

Also, do you simultaneously have another mobile device nearby, like a phone? If so, it might be worth turning Bluetooth off on that while you’re trying to get the sensors connected.

2 Likes