Spin down of Kickr Core with Wahoo (Fitness) App not working

When performing a spin down the Kickr Core disconnects when it spins down to around 16 kph, Tried rebooting the Kicker, uninstalling an reinstalling the app, turning blue tooth off and on

Hey @Dean_Purcell and welcome to the forums.

a few questions: 1) r u using the Wahoo Fitness app or the Elemnt Companion app? you should be using the wahoo fitness app. 2) also, do you have the latest firmware? 3) Have you tried rebooting your phone?

Yes, WF app. Have also tried rebooting the phone. Managed a calibration with Trainer Road. Have successfully calibrated with the WF app before on numerous occasions but can no longer

1 Like

Worth putting in a formal support ticket then. https://support.wahoofitness.com/hc/en-us/requests/new

I’m due a calibration myself and will likely do in a day or so. Using a Kickr ‘18 and my experience, like yours, has been pretty good before. I have had a couple calibration failures but mostly success. Putting in the support ticket helps the company track whether this is unique to you or more widespread.

Thanks will do

1 Like

Known issues with the Wahoo App. Devs are aware and this has a high priority to be fixed as it affects the entire Wahoo experience.

Thanks for that James. It is indeed annoying.

Dean

1 Like

I forgot to ask, r u using Android?

Yes, I am using Android. This is a new Kickr Core, purchased in October.

Dean

1 Like

Got it. I defer to Sir James then. I’m on iOS and have no issues. Android is being worked on as he said, as we speak.

1 Like

I have the exact same problem. New Kickr Core, bought it like 2 weeks ago and performed a spindown without issue. Trying to perform a spindown again today and it just keeps disconnecting the same way Dean describes. I’m using the WF app on an android phone. I’ve tried restarting the phone. Firmware is updated.

Look for a fix before Christmas is what I was told. I see this as a critical issue and a serious regression with the product. There may not be any updates after this is fixed for a while. With a big project there are lots of moving parts

2 Likes

I have a new Kickr core and I found that other apps in Android were very wonky, with lots of drop outs etc, but switched to iPhone and it runs no problems. So not just the Wahoo app others that are connecting to the kickr via Android (regardless Ant+ or BT) are not good.

Same issue here on my newish kickr core. Spindown worked fine on my android only 2 weeks ago but identical issue to what @Dean_Purcell has flagged. Looks like transition to new app hasn’t been smooth, eagerly awaiting a fix!