Wahoo App trouble connecting to KICKR Core

Hi All, im hoping the hive mind might have already come across and solved this. I haven’t used the Wahoo app in a while (only to calibrate the kickr core and check for firmware updates) and found that it had been updated as it looked quiet different. For some reason it won’t see the core at all. I can go to the SYSTM app and it can find the trainer, Zwift can find the trainer and MyWoosh as well.

Is this a known thing, is there a different app we should be using now to check firmware and calibrate the trainer?

im using an iphone 2020se with latest version of iOS 16. Thought I would check here first before submitting a support ticket.

1 Like

might be worth forgetting and re-adding the Kickr as a sensor. The WA is still the preferred method for checking/updating firmware.

Also, isn’t the latest iOS 17?

Hey Glen, probably should of clarified I was on the latest (ie last release) of iOS 16. I just updated to 17 last night.

I can’t get the app to forget the trainer as its not there in the list. I will try again shortly but I think im going to have to lodge a ticket.

so if it’s not in the list, you need to add it.

If you go in to the my sensors drawer thingy in the Wahoo App, there is a + sign that if you tap, allows you to search for and add sensors. Make sure the Kickr is plugged in, obviously.

What you have described is what i have been trying to do. I have restarted the app (multiple times) and made sure it has bluetooth permissions enabled. The manage devices list is empty as well.
When I try again I will make sure that all other apps on my phone are properly closed, just in case Zwift or MyWoosh are interferring with the bluetooth connection to the trainer.

1 Like

that’s possible too, it also doesn’t hurt to turn the bluetooth on your phone off, then on again (can’t help but think of the IT Crowd when I say that :joy:)

I’ve managed to resolve the issue im having. I manually closed all open apps on my phone (just in case there was an oddball app doing something it shouldn’t have), also needed to make sure my phone was able to connect to the internet, Wifi out to the my garage is sketchy at the best of times, and it connected to the trainer straight away. so all good now. At least I can now control settings on the trainer and spin down tests again (haven’t done one for a while).

Thanks for your advice and trying to help. appreciate it :slight_smile: