SYSTM App ends ride early

I am in a trial period and enjoying the SYSTM app, but seems almost every session my ride “ends early” or crashes. The system shows it written to calendar etc. as if I chose to end the ride, and there is no common just random durations and on different courses. I have managed to get a full ride in after restarting once, other times a restart does the same after a few mins, but ahead of committing to a subscription I am hoping to identify the issue.
The rides all show “this activity was recovered” in details.
Running on a MacBook/ventura.
Appreciate any help or guidance!

Hmm, I have been using SYSTM daily since Thanksgiving on an M1 Macbook. I have only had SYSTM crash one time and that was this last Saturday when I was running SYSTM in mini-player mode on top of a windowed RGT session, so that was an unusual circumstance.

I didn’t originally, but I’ve had enough stutters and pauses in inspirational videos that I now download all workouts. I do this early in the week for the next few days. I also never run off battery, always plugged in to power.

Never a bad idea to uninstall, download the latest and re-install.

I do this too. Sometimes the downloads can take a long time (~20-30 minutes), so I get them started well before I plan to do the workout. Not sure if the slowness is at my end or at the content delivery end.

What else do you have running on your computer at the same time?

If you have a look at Activity Monitor, how many spare resources (especially RAM) do you have while running a SYSTM workout?

Pretty much everything is turned off. I’m keeping an eye on BT dropouts, network drops (I do not see either but one never knows). I am thinking to try downloading as others seem to suggest in case it’s network latency or something else. I use TACX and Fulgaz on the same setup without issue.
I’ll keep track of resources on my next attempt. Might do one streaming and just see if it is looking poor at any point then try the download path.


When I’ve been streaming a workout and experience network issues, I don’t see the app crash, just the video part stops.

I haven’t heard of many reports of SYSTM crashing here in this forum, so it doesn’t appear to be a common or frequent issue. It will be a case of working out what is different about your configuration that is causing you to have this problem on such a regular basis.

One other option is to try a delete/re-install of SYSTM. Perhaps something didn’t go quite right in the download/installation process.

1 Like

I wonder if you’ve downloaded and installed the wrong software version. I know there are two software versions for “Apple” type products (sorry a windows user here) and you can run the wrong one on a MAC but it causes issues. I’d uninstall, download a fresh version making sure it is the correct app version for your machine and see if the fresh install helps. :+1:


I’m also going to remove and re-download and reinstall! Can’t hurt and yes who knows some glitch along the way. I have the silicon version so let’s see - thank you and everyone for the suggestions, I sure hope I can sort it out as it has been a great app to use (albeit I am leveraging the on location sessions at the moment!).


Thank you for pointing this out @DameLisa . Turns out the original link I used to download pointed at the App Store. Seems whatever version that was it was the problem. I have now tried that one, and the two (intel & apple) versions. Just finished on the apple version without issue. Noting the two Mac versions show the same info in “about”, with the App Store version being slightly different.
So looks good now, thanks again for everyone’s help!


Sorry can’t speak to Mac, but your experience is not normal.

I rarely get app crashes, and not for months now.

There’s barely any reports on here either, so I’d suggest uninstall and re install.

Also, speak to the minions (wahoo support team).
They have a wealth of helpful experience and knowledge.

Appreciate you’re on the trial, but hopefully you’ve seen the content, and support from the community are worth persisting for the benefits

Woop so stoked that seems to have fixed it!!!

Oh also, don’t subscribe thru the App Store, it is way pricier than subscribing direct to Wahoo via their website. Hot tip of the day :grin::+1:


Not only is is more expensive to subscribe through Apple, but it’s not transferable outside of their products. If you are using a Mac for example, you’ll need a second subscription for Android.