SYSTM Issues

Am I the only one who runs on tight schedules and when its time to jump on the trainer its time to go. Never fails that when I have a tight window to get my work done SYSTM has upgraded or is otherwise incapable of connecting normally. There is nothing that can start my day off harder than SYSTM acting up forcing me to miss a workout.

5 minutes to connect is fine, even 10 minutes is tolerable but when it starts taking 20 minutes to a half an hour that is simply not acceptable!

1 Like

What device are you running SYSTM on?

I run on a PC and if there is an update pending you can simply ignore it, for me it’s super fast even if I let it run through.

Also, can you clarify the circumstances of:

“Connect” to what? Again, on the same PC I find it loads sessions near instantly and picks up my sensors within ~20 seconds or so.

What is your internet connection like and how “noisy” is the area you have your trainer in?


It’s like why my bike computer works flawlessly until I have a big event :stuck_out_tongue:

Frustrating to be sure. For me though, outside of an update that takes a minute and occasional problems getting my HRM to connect, I am pretty much generally issue free.


The only truly firm rule of computing. Everything works up until the point you absolutely need it to…
That printer that worked fine yesterday when you were printing a silly picture to stick on a friends’ window now won’t work when you need to print coursework.

Your cycle computer is fine until the morning of a race.

Your HR monitor battery has lasted all year, but not only has it failed today on Full Frontal day, the entire drawer full of spares you keep discharged while doing nothing…

Computer been rock solid all year? Got a presentation to host at 9am? Here, have a BSOD


I hope I am not cursing myself here, but since going to Mac back in 2012, I have yet to face one of those.

1 Like

As was I until today. The latest update has screwed me. Nothing changed on my end and my internet is working great. If only these software engineers would learn to update in a way that is seamless for users.

I can get the workout to run but the clocks dont work. I am on my second device trying to make it work.

1 Like

I am having a similar issue, and I have an open ticket with the minions.

When I start up SYSTM on a PC, the Tacx is not fully recognized. I have to remove it, add it back on, wait till it recognizes the trainer, shut down SYSTM, and start it up again. I have the latest drivers, it started with the recent SYSTM upgrade.

This can take quite a few minutes and it is more than annoying.

fwiw, if the clocks/timers aren’t working that sounds like quite the glitch. Might be worth a complete uninstall and reinstall. At least that’s what I would do.

My pc, a surface pro, the same one I have used for the past 5,000+ miles this year. To the same wahoo kckr bike for those miles. But as a test I also tried my Samsung phone with the same result.

I get connected to the bike and he monitor but no video and although the tape on the bottom moves, the clock does not! It also took forever to connect to the bike. My network is working fine.

Two days in a row now that the systm workouts wont play on Android: Vicegrips being todays. Kind of worthless to pay for something that doesnt work. Ate there server issues?

1 Like

The NYC video streamer response time is higher than normal but no issues shown atm


What would be the response expectation, given that scenario - if thats something you can pinpoint?

1 Like

No idea :man_shrugging:t3:.

Just pointing out that the graph for NYC shows a bump in response time but we’re talking milliseconds. I’d guess it’s within normal limits tho cuz it’s all green.

I should add @Todd_Bettler (and welcome to the forums!) I’m just a regular user like all y’all. Just that I’ve been around for a bit longer than some.


Got it and thanks. Yeah the video just sits there, for minutes until lunch is over :expressionless:

1 Like

I’ve had a few GSOD (grey screen of death) on Macs, although very rare.


If you haven’t yet, it’d be good to contact the minions with the issue. The more formally registered complaints the better the likelihood of them finding out about it and finding the fix.

You can do that here:

1 Like

I did an uninstall/reinstall as you suggested. Same result. Then I put in a ticket.

1 Like

That sucks yakbaIIs! Keep us posted if you remember.

Update, same exact issue on my samsung smart phone. It has to be them. I uninstalled/reinstalled on it as well.

1 Like