My SYSTM app on PC is VERY SLOW to open or to finish workouts

I only run SYSTM on my PC laptop, and for a few months now, it has been VERY unsatisfactory.
I have uninstalled the app and reinstalled the app about 3 times in 2 or 3 months, and the problems continue.
These are consistent issues ever since this behavior started:

  1. Opening the app does not appear to be doing ANYTHING for a long time after I double-click the shortcut. Same is true if I right click and choose Open.
    No hourglass showing that anything is occurring, no window of any kind begins to form, it really looks like I didn’t even activate anything.
    After about 30 seconds or MORE, I FINALLY see the window open and in sufficiently good time, it does indeed show up and I can begin using it. After that, it seems good, GENERALLY. I do still see some occasional slow opening of a workout from the Library, a long hang before it shows anything, but that is not every time. Today, it WAS long, so much so that I wondered again if the app was going to stay open at all but finally the window showed up at the workout chosen.

  2. Once I finally actually START a ride, it has usually been good, but today, EVEN AFTER uninstalling and reinstalling the app completely, with a reboot of my PC in between, and with confirming that all showed up properly, (i.e. it already had all my data in there, though I did have to reestablish my Strava connection first), the workout took a VERY LONG TIME to begin, maybe 15-20 seconds of just nothing once I hit the Start button in the window. I was afraid it had crashed but it just was hung for a bit and then proceeded as normal.

  3. The workout did fine, no issues at all keeping up, no glitches throughout… UNTIL!!! And this is #3 because this has been true ever since these problem started a few months back: When I FINISH THE WORKOUT, the video stays up but STOPS MOVING and progress STOPS ALTOGETHER for MANY SECONDS. The Start button shows up though I’ve done nothing to stop or pause anything, I’m still pedaling away, but things are actually paused. I hit the Start button but it immediately stops, instantly in fact. If I just pedal, things do nothing. I try clicking the Start but it does NOT KEEP the video going, nor does the time progress. It’s like there are only a few seconds left to go but it will not finish them.
    Today, I actually tried for the first time to click the Start Button over and over and over as fast as i could click on it, and I could see the fading video barely moving, haltingly, and after MANY clicks, it finally stopped the workout and brought up the SAVE WORKOUT option.
    In the past, I’ve tried hitting the FINISH WORKOUT button up at the top, but that hasn’t had any effect either. The app WILL EVENTUALLY finish and stop and offer the SAVE button, and I have to just wait it out, sweating bullets that it’s going to lose my workout altogether or even go back to the start of the workout if I hit the Start button in the center of the screen. Hasn’t happened yet, thankfully, but it sure isn’t a happy experience.

If anyone has any clues or experience with similar issues, please reply.
For what it’s worth, my PC is definitely not ancient, nor underpowered, nor slow, nor short on memory. (Even if I may qualify on ALL those counts.) :slight_smile:

1 Like

I don’t have a PC but I may also qualify :joy:

Have you put in a support request to the minions yet?

I use a Mac for cycling workouts and either that or an iPhone for others and have sorta kinda noticed #3 intermittently in non-cycling workouts where I have to drag the slider to complete the last couple seconds or the Save dialogue box doesn’t come up.

I haven’t noticed what you’re describing in any cycling vids. Though, those haven’t been many for the past few months because weather has been good.

Did you purge SYSTM leftovers after uninstalling it? If not, it might be worth a try.

Open Windows Explorer then navigate to the folder:


(just copy it (including surrounding %s) into the address bar and press enter).
Roaming folder will be displayed; remove the SYSTM folder listed there.
Go up one folder and open Local folder. Remove the SYSTM folder listed there, too.

I’m afraid this is one of those things wherein I’ll only become more and more qualified with time… :- :unamused:
I’m destined to become eminently qualified!

I have not yet put in a support request, @Glen.Coutts … Like you, I’ve only done a little indoor of late, both because of a stretch away on vacay, as well as wanting all the outdoor rides I can get ALWAYS, but especially at this gorgeous time of year!
I’ve been hoping this was happening enough that maybe the minions were already aware and working on it and it would magically solve itself with another update. That hasn’t happened. (And I am on the latest version.)

Thanks for confirming the #3 issue happens to you also, and I never thought of dragging the slider to complete it! I’ll try that next time too.

Thank you, @macnuts for that info. I have not done that because I didn’t know how to begin.
Just for the sake of complaining :roll_eyes: I will say that while this is WONDERFUL to have info about how to do this, it still gripes me that the app uninstall may not do these things properly itself! I consider that basic responsible app design, and it takes me back to the era of Windows95, when it seemed that half or more of the programs did NOT do this well at all, and left users to become educated for themselves if they wanted anything close to a clean running system.

I really don’t mean to be unfair at all, and I understand and appreciate that slip-ups happen, but my experience with SYSTM has gotten quite a lot worse of late due to this and other glitches that really need to be addressed and the app improved to make it a friendly platform for more users. The RGT issues were worse, for me, at least, and I sure hope SYSTM doesn’t slide backwards in this regard.

I will try exactly what you have explained here and report back, although it may be a little while before the test of time proves it out. Previously, on about the first reinstall due to glitches, it seemed all was fixed again but within about 2 indoor rides, it was right back where it started, and has gotten worse.
Hoping there’s a corrupt file involved, and that your suggestion may help rid my system of the offender!

@macnuts Thank you for the helpful info about PURGING the leftovers. I followed your instructions, after first Uninstalling SYSTM yet again, and then I went back to my Desktop.
The Shortcut to SYSTM was still there so I deleted that.
Checked what was showing from the Start Button, and it still had SYSTM pinned to the Start, showing in Apps. I right-clicked and Unpinned from Start and it was gone.
Then I looked at the All apps list and it was STILL there down in the list, right-clicked and it gave no delete options. Tried the Uninstall option again (I had already uninstalled before, and rebooted) and it took me back to the Settings/Uninstall Programs lists, but no SYSTM showing there, as expected.
One more try, back to the Start button, All apps, found SYSTM in the list and this time LEFT-clicked it, as if to Open the app, and THEN Windows came to its senses and said something to the effect of, This shortcut does not point to anything and offered the option to Delete it, which I did.
All cleaned up finally, I think!

Then I went to Wahoo and found SYSTM and downloaded fresh again, first making sure my previously downloaded Setup files were also deleted.
Did the fresh installation and this time, for first time yet with these reinstalls, the App made me sign in again to Wahoo as part of that process. It also opened the App window VERY Quickly, no 30 second delay of nothing happening. So far so good!

The App also warned about the STRAVA and GARMIN Authorizations needing to be redone, but when I checked them, they both showed as Connected.
Doubting that would hold, I disconnected both of them, shut down the App, reopened again, and then Connected them both again. STRAVA just reconnected immediately, with no new log-in. GARMIN sent me to a new Log-In page and I logged in again. Both show as connected as of now.

I’ll see how it goes from here, maybe can force myself to do a short ride indoors again but the outdoors is calling, so… :thinking:

I’ll report back again…


I rode Women’s Tour de Suisse 1 this morning. 1hr 18min. Started up just fine. Video played just fine. But… when I finished and hit save, it took 3-4 minutes to save my workout. I was able to do multiple stretch exercises while I waited for it to save. That doesn’t even include the time to wait for the calendar to sync afterward.

1 Like

Well, it isn’t looking very promising… I just reopened the SYSTM app again, not really intending to do a workout, just to check how the opening speed is… From double-click of the shortcut, which started a spinning icon for a couple seconds, until anything else appeared took almost 30 seconds. There were no other programs running, nothing else open… My system is not anything close to slow, but this app crawls opening up, and crawls for the last seconds of a workout. :confounded:

Out of curiosity, does the site load and work speedily?

1 Like

If what you mean is load pages, data etc speedily, it DOES for me. Of course, I only opened the link, glanced through Calendar, Library, etc, and chose a September Challenge ride to see if it loaded the initial description etc, which it did rapidly.

I couldn’t test it from there, of course, since you then have to “download the app to play.”

Sounds like there is a communication issue to and from the Wahoo Cloud facility. I’ve noticed the app on my phone is taking longer to load than it took a while back. Interesting is that the app running on my Mac takes less time but I’m using it off-line.

1 Like

Have you tried restarting your router?

The behavior is clearly not a router issue, (but yes, the router has been restarted during the period under discussion.)

And as of now, the same DELAY is back as I opened the SYSTM app on the PC. SLOW SLOW SLOW.
Bet if I do a workout, the last couple seconds will take forever too.
This is just SAD…

Sounds like you have serious network issues. I can open the app on my mobile and sometimes it immediately responds and sometimes it takes a minute to display everything. It’s called network saturation and there’s very little we can do about it. There’s been complaints on software that requires constant connectivity of disconnecting and reconnecting issues. And it depends on where you are and how you connect to the servers.

If it is network, why is the problem only when I start the app and finish a workout? It is connecting and feeding constant data throughout the workout, and that never has issues. Video is steady throughout, etc.
And doing anything else in the app, changing from Library to Calendar etc is always fine and snappy.

Furthermore, opening the app on my mobile is snappy, no delay. Yet it’s using the exact same WiFi network and provider as the PC.

Interesting. However, there are network differences as your mobile may be connecting to on CDN and your laptop a completely different one (this happened to me and my laptop runs through a mobile hotspot). Plus content is delivered by different servers than data in many cases. Only a person from Wahoo can confirm what is going on with data and content delivery,but I suspect this is the case.

Just want to raised the problem again, because the same crap still happens. Even if I cleanly uninstall and then reinstall the app, any benefit doesn’t last more than a day.

1. The startup of the app still takes a good 28-30 seconds from double clicking the app. 30seconds of absolutely nothing indicating that one has even tried to open it, so I tend to wonder if I actually did, but I know now that it is just SLOOOOOOOWWW.
And this is on a fast and capable PC with plenty of memory. Doesn’t matter if anything else is open or not.
That’s gripe one, and the least problematic.

2. Number 2 is pretty similar. The app is open, I’ve selected a workout to ride, and I get a black screen of nothingness for quite some time before anything loads in the window at all. More thumb-twiddling. This happens on EVERY WORKOUT.
It finally loads and generally starts running w/o more issues. The workout progresses as it should once I get past that poor startup.

3. Number 3 is the most aggravating of all. The workout finishes up ALWAYS WITH RIDICULOUS DELAYS. Video comes to an end, the PLAY/PAUSE button comes up in the center of the screen, the countdown timer has already reached 0.00 and the workout SHOULD be over and I SHOULD see the Popup window with WORKOUT DONE! and the SAVE option, but that takes a long time to appear, and I’m madly clicking the PLAY button because it is PAUSED in a fraction of a second from when I click PLAY. The whole screen is like a strobe light flashing from PLAY to PAUSE multiple times per second as I click to get the blasted thing to finish up.

I tried to post a tiny video of this but the picture insert function won’t accept any video. I’ll describe the action as best I can.
**NOTE that I only took video AFTER a long fight of “CLICKING PLAY/PAUSE ALMOST ENDLESSLY” TO GET THE WORKOUT TO FINISH. It went on for somewhere around 20-30 seconds, MINIMUM. I was able to capture the last 4 seconds as it finally resolved. (After taking some months of life off my trackball mouse click button!)

The completed workout time showed 38:01 for what is a 36:05 video, HALF IS EASY. I paused very briefly to change to level mode when I reached the intervals. I also recorded on my Garmin FENIX and stopped it when the workout ended but hadn’t really stopped, and the FENIX record was only 36:53, including my change to Level Mode time.

I can only assume I’m not alone with this hassle because I know others responded on other threads previously saying they had similar behavior. I wondered if this is what caused @Critmark to lose out on his Sufferlandria Badge… I thought he had issues similar to mine before, and had found a way to drag the slider the last tiny bit to get it to end??

I just want to be able to use the app without these aggravations EVERY TIME, but nothing I’ve done by way of uninstall/reinstall has helped. I do not believe the pattern is consistent with any network issues. It is these 3 specific symptoms I described above, and they happen EVERY TIME I use the app. No glitches during workouts; once I’m rolling, it goes great… UNTIL.

**If any of you have these issues as well, please say so! **
If someone has any idea why this is happening, I’d sure like to find a solution!!

@DouthatBiker I have seem issues 2 and 3 from time to time and think it relates to the workout player which is supposed to be rebuilt at some point. I believe I read somewhere that the same workout player that was in the Sufferfest app came over to the SYSTM app.

I don’t remember ever seeing issue 1 - I would recommend delete and install but it seems like that isn’t working for you. Have you reached out to support to see if they have any ideas?

1 Like

I experienced #1 for a while about a year ago. It got slower as time went on and eventually opened as a black window which consumed a surprising amount of system resources then either closed by itself or had to be forced closed. It was unique to the windows 10 machine in my pain cave, my windows 11 notebook and android installations worked perfectly. Reinstalls, deletion of all traces, and reinstall didn’t help. One of the Minions did something on Wahoo’s end which resolved the problem, incredibly quick response time. It has not recurred.

#2 and #3 happen to me once in a blue moon, the player definitely needs an update. The player also needs an explicit switch or at least an indicator as to whether pausing the video stops the timer or not - I might want “credit” for stopping to do more reps or work on a pose, but not for a quick break to let the dog out. #2 and #3 seemed more frequent when #1 was proceeding to deteriorate.

1 Like