Systm not connecting to Shokz OpenRun headphones

Hi, I have a kickr, heart rate monitor, and set of headphones that I’ve been using, all connected by Bluetooth to an iPad pro. Everything worked fine until about a week ago. The System X app will no longer put audio out to the headphones. The headphones work on the same iPad on all other programs including two browsers, Spotify, and RGT.

Does anyone have any ideas for a setting that I might have inadvertently changed or anything else that could cause this? I waited a few days between trying to use the headphones and it’s the same failure both times.


1 Like

is it at all possible that you have the sound toggled off on SYSTM. I have had that happen, seemingly out of the blue, as in I don’t recall turning it off myself.

Easy enough to check but you can only check after you start a video. You dont have to save it but to check the settings you DO have to start it.

Click the gear icon, top right, then click settings. There is a toggle switch for music and for sound effects.

Edit: also, welcome to the forums @Peter_B !


Well, that’s mildly embarrassing, but yes it did fix it. Thanks for the suggestion and the welcome, Glen. I thought I tried turning those on a few days ago when I wasn’t getting any sound, but perhaps I’m mistaken or something else was going on at the same time back then. Thanks again!


It’s happened to me. Glad I could help!

maybe a useful FYI, i’ve had similar issue and noticed that if I had been listening to spotify, previous to launching Systm, when I start the training the music had ben turnedturns to off without my intervention!