SYSTM rolling off resistance when I’m below target?!

Just tried to ride the cure and on a quarter of the hard efforts I would wind it up but could never reach the tgt power as the app was taking resistance **off ** the trainer?! Gave up when it came to the 90 sec ftp effort as I was just spinning higher and higher rpms but couldn’t reach tgt.
Bug? New software? Either way it’s not helpful!
I’m using a 5th gen iPad mini with a fairly old Tacx Flux but never had an issue on the old suff app.

I’m experiencing this too. Also on a Tacx Flux, very first original one I think. Happening on both iPhone and macOS apps as far as I know, don’t have other platforms to test.

At first I thought maybe I wasn’t in ERG mode, but the resistance does increase in the sprints, just not enough to meet the targets. I ended up changing up gears far more than I should have to, and as a result after the sprint ended, the trainer wasn’t able to get back down to the next lower power target! Definitely something not right there :frowning:

As a datapoint I did notice this about a year ago on the macOS Sufferfest app, and switched to using my iPhone instead, which was fine until this week. Now, both platforms are doing this :cry:

I’m using the TacxFlux S which is fine, but I have an original Tacx Flux in the paincave so I’ll double check on that. Check the trainer firmware is up to date, as that might be the issue.

1 Like


Similiar problem here with Flux 2. The power is -20 watts below target. High cadence (>120 RPM) is not detected. Never happened before with The Sufferfest App.

Seems that we may have a theme with the Flux, eh? Will you all please contact our support team so that we can get this logged and looked at?


Will need to watch for - using an Ant+ dongle on OSX and all is working fine so far.

I think newer apps use the newer Bluetooth protocol. It should be backwards compatible but hardware with the older protocol probably needs a firmware upgrade. But yep, might be worth a bug report

I’m on Flux firmware version 3.3.40 / 1.1.6 which my Tacx app says is the newest.

I’ve submitted a support ticket this morning though with as much detail as I can muster!


Nice one, can you update us here if you get a resolution please?

1 Like

I had the same issue today attempting 14 Vice Grips, also on a first gen Tacx Flux.

I’ve lodged a support ticket, let’s see what happens.

1 Like

I tried tapers cadence was reading 120 no matter what I did, then power went to 0 wahoo kickr v5

Are you using BTLE or Ant+?

BTLE, using my iPhone 12 pro with iOS 15.

Power still not reading correctly today when attempting 14 Vice Grips again following recommended corrective action. Off to enjoy Zwift, at least that’s working for me.

To reiterate, my set-up worked perfectly prior to SUF transitioning to SYSTM.

Hey everyone, we’ve done some testing on our end with a Flux on the latest firmware, a BTLE connection, and Ant+ turned off as Tacx recommends if using the BTLE connection. We haven’t been able to reproduce this. This doesn’t mean that something isn’t happening, but that we can’t put our finger on it based on the information that we have on hand.

If you are still experiencing problems with your trainer and you haven’t contacted support, please do that. The more information they have, the better.

Hi Cody

I’ve got a ticket raised about this at the moment, although I’ve had to register a separate account on here as my Suff details don’t let me log in….

Not sure if it’s helpful or not but please see screenshot from a video of the issue. Even roughly hitting the cadence target the wattage seems to get stuck about 20 / 30 watts below target and nothing will ‘reset’ it to be working again.

Tacx Flux 2 - latest firmware
Devices it’s happened on:
iPhone on iOS 15
iPad on iOS 14.7.1

Support advice so far is to delete old Suff apps on both devices but I’m not sure how this will affect the issue as they are not running when I’ve experienced the issue.

1 Like

Hey, I have a Flux1 with 1x set up (36t + 11-44t), and this happens in the bigger cogs, esp with low cadence MAP intervals. Only workaround found so far is to shift up to the smaller cogs. There used to be an article buried somewhere on the TacX site, not sure where it is now, and Garmin support was of no help.

Hopefully this helps and enjoy the pain shakes.

Thanks for the input Erick. Sadly this issue has only happened for me since the SYSTM update.

I use the little ring half way up for ease for ERG mode. I did actually try the big ring too to see if it prevented the issue happening but it didn’t.

I’m tempted to get a free trial on another app to see if there are any ERG mode issues as could then narrow it down to being a trainer or app problem.

My ticket is still outstanding.

Response from support a few days ago was there is a known issue with iOS devices and that I should try SYSTM on a Mac or PC.

I put SYSTM on my MacBook Air and had same issue.

I’ve cancelled my membership as I’m not paying for something that doesn’t work. I’ll rejoin if and when the issues are resolved.

My support ticket went through the usual motions of power cycling the trainer (like I wouldn’t have tried that already), performing a spindown, unpairing all other devices, closing all apps, etc. Really anything other than admit they might have introduced a problem with their app update as it worked perfectly fine two weeks ago.

It sounds like you got more useful responses than I did by them admitting there was a known issue with iOS devices but as you say it happens on Mac too and I’m not really in a position to run it on a PC to try that.

Lost patience and cancelled my subscription too. Joined TR instead which seems to work perfectly. I’ll miss the videos and the humour but at least I can do a workout now.