Tacx Flux connection problems

I’m suffering on a Tacx Flux 2 and a laptop running Windows 10. All has been good until today, but then I got a connection error saying something about Squirrel updater not working.

I uninstalled and reinstalled the app but now it will find my turbo but won’t hold the connection over Bluetooth. It works fine on ant+ so there’s a solution, but does anyone know why the Bluetooth might be suddenly unstable?

I’ve put a call into the minions but wondered whether anyone else has had/solved this problem?

Suffer more people!



I hope you got my email reply! For anyone else with squirrels :chipmunk:… check out this help article:


Since the last app update on win10, my BT may have been unstable too.
One day, I lost my hrm. Next day it was my Cadence. the trainer itself also did a few dropouts.
Haven’t tried to use the ant+ yet, to see if it holds connection here.

Tacx Flux 2
Tacx Cadence sensor
Wahoo TickrX

Haven’t had issues like these before.

1 Like

Just curious, did you update the TacX firmware recently and that is when the issues started?

1 Like

It’s been many months since there was an update for the Tacx, so no.
Only thing I’ve changed, is rotating my setup 90 degree. Now the wall is on the left side of my setup instead of on the right… Else nothing has changed - apart form SUF update 6.16 I think it is?

1 Like

Well that rules the firmware out! Have you tried running SUF from a different device like an iPhone?

1 Like

Hi guys

There was a firmware update for the Tacx Flux 2 recently, but I updated that after getting the recent issues with my misbehaving squirrel.

The Minions have suggested I try removing all connections and reconnect everything from scratch, which I’ll try when I next suffer tomorrow.

The ant+ connection works fine and weirdly my Bluetooth HRM (Polar H10) connects fine too so it’s definitely a difference of opinion between the app and my Turbo, but perhaps something to do with the latest Windows 10 update.

I’m grateful for the minions (esp. Dame Therese Kirchner), this is way too tech for me! :joy:


This might help?

I have a Flux OG and here are the steps I follow on iOS to avoid BT connection issues, might work for windows?

  1. Ensure trainer and all nearby BT devices such as speakers are off/unplugged
  2. Close SUF app
  3. Power down phone
  4. Wait to ensure it is really off
  5. Turn back on
  6. While waiting for device to boot plug in Flux
  7. Open TacX training app
  8. Verify app and trainer are talking to each other
  9. Use app to calibrate
  10. Verify power and cadence readings are in correct range (if not, recalibrate or start over)
  11. Close TacX app
  12. Open SUF app (+plug in corded headphones)
  13. Pick workout
  14. Turn on TickrFit
  15. Start workout
1 Like

I’ve always been carefully not to have other BT connections open at the same time.
When I’ve lost the cadence or HRM, sometimes I can remove the unit from the list, and search for new devices.
The sensor pops up fine, but either it won’t connect (Stays yellow) or it looks like it has connected (turns white), but it won’t show the cadence/hrm icon, as if it doesn’t know what it’s connected as.

1 Like

Hi guys

We’ve solved the problem!!! With some help from Alex The Minion we’ve sussed it (SUF’d it??).

Basically my turbo was trying to connect to both my laptop and the SUF app (which I was running on my laptop) at the same time. I went into the Bluetooth settings on the laptop and removed the turbo from the list of BT connected devices, as well as removing it from the list of devices in the SUF app. Then I restarted the turbo and re calibrated it through the Tacx app on my iPhone. Then I disconnected it from my Tacx app.

When I went back into the SUF app and tried to connect the turbo in the usual way it worked just fine.

I’m using a Surface Book 1 running Windows 10 (fully updated) and a Tacx Flux 2.

Thanks to the minions for their help, I can suffer in full Bluetooth glory again now, hurrah!


Nice, Thanks for sharing its very informative for me.
Java Training in Pune