Using SUF with garmin virtual run

My garmin 945 has included virtual run (which can also be used for bike, it’s just receiving Bluetooth data) which would let me link my heartrate from my watch (or from my strap to the watch via ant+ then to the app via Bluetooth) so I can use my iPad instead of my older computer, which has had communication problems.
I’m able to pair the app and trainer, and the app to the watch, but on the watch end all I get is “ready to pair” even though it shows the iPad connected.
The tech support at Garmin would like to know if there’s a troubleshooting page in SUF for connecting the watch and Bluetooth, I guess. I don’t see the relevance, but it’s what they’re asking for. My Google fu skills didn’t turn up a page like this. Anyone else know?

1 Like

From the picture it seems like your HRM strap is paired with the app. If so, it may not also pair with the watch. I have a Suunto and encountered something similar. I had been doing some strength training and used the watch and HRM to record and then when I jumped on the bike the HRM sensor didn’t show up and I then realized that it was paired with the watch. Hope that helps but if not I would suggest asking the minions.

1 Like

Strap is only ant+, which the iPad can’t see. So the strap is talking to the watch, and the watch is paired to the iPad but can’t seem to realize it is. I honestly can’t remember if I had the strap on at this point, either - I’ve tried so many combinations is hard to recall what I tried what day! Thanks for the suggestion. I’ll try again today.

1 Like

Hi @Dawn2.0!

There’s an article here that links to the instructions on how to pair the watch to the app:

If this isn’t working for you, can you please send us an email at so we can troubleshoot this with you?


I have the same issue with my new Fenix 6S. Did you get the problem sorted? I can connect to Zwift fine over Bluetooth using the virtual run but I’ve never been successful with Suf

hello therese,

thank you for your hint to the article.
but, i still hit the same issue as @Dawn2.0 and @Rothwell with my fenix 6X Pro Solar (with mac Desktop app 6.18.0)

the app itself show a successful connection (and receives the HR data, too), but it seems, that the BT connection “handshake” is not finalized. so, it is not possible to start the activity timer on the garmin device and after a timeout, the garmin device closes the “open” activity screen. this happens mostly exactly during a demanding interval :slight_smile:
(remark: with the zwift-app, the garmin device can establish a successful BT connection)

pls, can you check the BT connection (especially the finalization of the pairing)

thanks in anticipation

I have the very same problem on Win10 with Garmin 245. Garmin will show “Ready to pair” but won’t allow to start “Virtual run” and as a result heart rate drops out 30 mins into workout. Furthermore, I often struggle to connect watch via Bluetooth: it will be added in the devise tab but won’t transmit heart rate. Need to restart bluetooth and SUF few times to make it connect.

I really like the training sessions but there are too much connectivity issues. E.g. if I want to do the second session in a row, my Elite HT won’t be connected in ERG mode anymore. I’ll need to restart the trainer so that the ERG mode works again. This heart rate issue.

I understand that for good connectivity one needs a reliable behavior on both sides, application and device, but somehow I found that all works well in Zwift with the same laptop and devices.

I have the same issue with my 945, can’t start virtual run because it seems the Garmin isn’t detecting SUF app, though it IS transferring HR through Bluetooth to it…

Has anyone figured this out?

Exact same issue here with SF. Any fix known yet?

@Patrick_LaRoche @karl_bm @pfrrzzz @Kostia @Rothwell My apologies for not getting back to this post in a timely manner. If you’re struggling with device connections or pairing your Garmin watch, please email us. While the forum is great for finding solutions and shared problems, we can sometimes be busy working in the help desk and don’t see the replies here. We are so sorry about that!

Please email us! ( or submit a ticket!

Same here - I’ve opened a ticket with support to see what can be done about this

I’m having this problem too. Zwift is fine. Wahoo SYSTM is not.

Did you get anywhere with support @Dahnhiller ?