Android App not registering Kickr, Tickr, Speed/Cadence

Just started SYSTM and can connect my three Wahoo devices above to the app, however when a workout loads the app doesn’t connect to my Kickr, Tickr or Wahoo Cadence sensor. I have a windows based computer which I loaded SYSTM on and everything worked great. Anyone else having this problem? BTW, I’m on a Samsung Galaxy S22+. Any help is appreciated and thanks!

Hi @Woj usually when I go to run a workout I usually need to remove my devices Tacx Neo 2 and Polar H10 in the Settings menu top right corner then I go to Add Devices and they both show up whether it’s via Bluetooth or Ant +. I have an IPad and a MacBook and I always remove them first as they just usually sit showing connecting but never actually connect. Are you waiting for them to connect automatically ? Have you tried doing this ? Go into Settings then Add Devices.

Sorry @Woj not settings my mistake it’s devices you want then Add Devices.

Thank you for reply. I’ve tried that several times. The Kickr and cadence ended up connecting, but not the Tickr. Pretty intermittent. I have a VPN that I disabled as well, too no avail…

I’m sure your version of SYSTM is the latest software, just make sure the Ticker is up to date too, glad the others connected

I use a macbook, and typically have to turn bluetooth off and on before every workout to get things to connect. It’s pretty quick (much quicker than deleting / re-pairing devices).
I don’t have a Tickr, though - so can’t comment on that.

There seems to be an Issue with Android devices via Bluetooth either not connecting or dropping out halfway through a session which is damn annoying to say the least. I have no connection issues generally with my trainer etc but my main problem is the HRM just loosing connection with the app on my android phone and once it does it will not re-connect during that session no matter what I try to do whilst still continuing to ride. It dropped out during my FF test so I didn’t get any CTHR figures either which was doubly annoying. There are plenty of threads on here about this but for me nothing has worked so I need to review my whole set up and maybe dispense with android altogether?.