App bugs

Anyone else having problems with the ‘settings’ tab on the app. Everytime I’ve tried to switch from erg to level mode or even touch the screen the tab disappears never to return.

Tried restarting devices.
Tried deleted and reloading app.
Tried deleting cache etc

Any ideas?

1 Like

I had this happen on my android, but uninstalling and reinstalling fixed it for me. The SYSTM installation on my Windows machines was recently corrupted to the point where where the only thing that fixed it was deleting all SYSTM files in the relevant user/AppData/… directory and re-installing the app.

Yeah…I think I’ve done everything I can…assuming it fixable as it doesn’t seem to be happening to everyone …and it’s android too…Samsung devices…Google devices…:man_shrugging:t3:


So far

Updated app
Deleted app
Deleted cache
Deleted storage
Checked software updates on Android 11 and 13 (on Samsung tab A and Google Pixel 7.
Reinstalled app.

Still bugging on settings drop down…this now means (as ai deleted app cache and storage that it unpaired from my Atom and HR monitor so I can no longer connect either and thus the app is as much use as a chocolate fireguard.


Pixel 4a, had this same problem. Clearing cache and storage worked for me. It did it for 2 days then has not done it again since. I also noticed that while it was happening in cycling workouts, it did not happen in strength workouts. The only difference there I could imagine is that cycling is picking up and trying to connect to your sensors. Shot in the dark but maybe try with bluetooth off?

Decent call…but without ant+ on either device that’s not gonna work.

Can your Samsung tablet perhaps handle ANT+? Before I switched to a Pixel, I had a strong preference for Samsung phones because it was possible to use ANT+ with them, but when I needed a new phone Samsung wasn’t price competitive. Not sure if that hardware and driver capability is still in their products, but worth a google search.

Even if Samsung can handle ANT+, STSTM on Android can’t. It is BT only.

Samsung stopped supporting ant+ some time ago.

And the app isn’t working on Samsung or pixel. Other apps are connecting fine

Android may be the issue…but as the helpline are still going through the usual ‘switch it on switch it off’ box ticking it may be a while til I ride again using Systm.

Oh for sure, just wondering if it’s a bluetooth bug, that might at least isolate the problem. Funny enough I went for a spin after I posted and it did it again, but cache/storage clear solved it again too.

To be clear

Not a connection issue…BT ant+ and internet are all fine. Other cycling apps are fine (but obvs not as interactively good as system).

The issue is when I press play on any session usually the settings menu will appear…then as soon as I touch the screen it disappears…never to return.

Thus presently I am unable to change any settings or connect any devices.

Systm help has been minimal so far and it appears they don’t work weekends as I’ve no updates.

Actually I noticed the same the other day on my android device - couldn’t get the settings back. That’s definitely a new problem, I’ve had no issue previously (though I run it on android rarely tbh).

1 Like

Obvs I don’t want anyone else to have problems…but if its a bigger issue then it might get sorted sooner. The first place I looked was on here (forum) and was kinda disappointed it was just me :man_shrugging:t3:

No updates from Systm Help. No possibility of refund (I’m annual) and seemingly little likelihood of the app issue being solved anytime soon.

So basically I’ve paid for an app I can’t use …can’t get help from the app developers…


@Ttreebo What country are you in? There are phone numbers to call support at the bottom of the linked web page.

Hope you are able to resolve the issue!

Thanks for that…so far…no one on that line has offered a response (UK)

I’m having exactly the same issue today, android phone tried everything you’ve mentioned still no joy.

The more the merrier…:no_mouth:…hopefully not for long.

Yup, still getting this on and off but clearing cache/storage continues to work, though I had to do it twice yesterday. It’s still isolated to cycling workouts, have not lost the menu in a strength workout so it’s something with the cycling UI. Have not noticed if it’s specific workouts that trigger it, 10 min warmup did it to me yesterday, I couldn’t connect to a sensor, bailed out of the app then the menu bug started when I opened it back up. Hopefully they get their crap together and dig into this, I use my phone almost exclusively, if the cache clear stops working I’ll be SOL too.

Had not seen this thread.

One plus android 10 not allowing access to the settings bar. I’m not 100% (never really needed to switch mid video) but it seemed to be working during the tour.

The app still seems to be recieving heart rate, cadence and power fine as my strap matches my fenix. It also is controlling my trainer fine for power changes.