Can't switch from erg mode to level mode?

As subject, systm app isn’t letting me switch from erg to level.

Tried turning trainer on and off, disconnecting reconnecting, restarting app, restarting phone, firmware update on trainer etc. I’m using a wahoo kickr v5 as well so can’t run a spin down.

I can see the option to switch mode on settinga but when i click to open the drop down menu nothing happens.

Which OS? What version?

Android version 9 and version 11 (tried it both my phones)

Are you running the Wahoo Fitness app in parallel by any chance?

…. and if you are, don’t.


In parallel as in on both devices at once? Nope tried on one then the other. Tried uninstalling from device as well. It’s weird it’s worked fine before.

Does the Wahoo Fitness app let you change modes?

Just checked, yeah the workout pages seem to be working perfectly. They’re just the same as if you’re using the elemnt head unit to control the kickr. I don’t think it’s the kickr, it seems to be a software issue with systm, it’s literally just not responding at all when click the drop down menu to change mode.

Very weird! I’ve not tried level mode in a few weeks - I’ll try to remember to try it out tomorrow morning.

Good luck with your troubleshooting.


Same thing with my android phone. Called tech support; they are looking in to it. Found a work around on my chromebook. If I highlight the ERG/Drop down menu, then press the letter L, I can get to Level mode. Otherwise, we are waiting for a fix, I think…

I tried uninstalling/reinstalling/repairing/switching on and off. Nothing worked.

I’m on Android 12 with a Google pixel phone. As noted, same thing on my Chromebook.

Yeah tech support got back to me this morning, looks like a bug with the latest software update! They’re looking into it so hopefully gets sorted soon enough.

Sorry about this issue, guys! It’s affecting Android. We’ve locked onto it and are working to fix it as quickly as we can. In the meantime - and I know this isn’t ideal for those looking for a true level mode – but you can adjust intensity in the workout player by going to gear icon > settings and making adjustments there.

1 Like

Sorry… That’s a real pity - or should I say a big joke? Was on my half monty and HAD to change to Level Mode but couldn’t do so. 2 months of Training plan chrushed in one Session. That all for 15 € / month.
I came over from Zwift this january. Now I think, I’ll go back there. Really liked the SYSTM Plan, but now I’m all disappointed :frowning:

It seems to be a bug in the latest software update. I’ve had it since January as well with no similar issues. Looks like they’re aware and there’s a fix coming. Must have been very frustrating realising it’d happened mid test though, I’d probably have launched my phone out the window if I’d noticed the fault midway through a ramp test haha, luckily i was just trying to change it for a sprint workout!

I wouldn’t say your training block is wasted though, the gains will still be there. Hopefully this gets sorted quick and you can retest.

1 Like

New version is up on play, i uninstalles and redownloaded and it’s been fixed.


New version is up on play, i uninstalled and redownloaded and it’s been fixed.


Correct! The Minions jumped right on this problem and worked hard to get it fixed as fast as possible. The new updated addresses the issue and so everyone should be able to flick between Erg/Level mode to their heart’s (and legs’) delight. Sorry for the hassle everyone and thanks for the patience and understanding. Onwards!