Device connection is ugly

It makes 10 days i try to use the application. On windows or Android, it’s always like to be in hell. Some times it works, my device is recognized, but speed is always swithcing from 30Kph and 250Kph. But most of the time, it just says Connection problem.
So i stop Bluetooth and start it again.
Then i switch off the Home Trainer, and switch on again.
Last time i tried during 30 minutes before beeing able to ride, with a wrong speed.
Now, it makes more than 40 minutes and it’s still failing.

It’s sad coz it seems to be interesting, and video are great, but the application bluetooth connection is such a failure.

Any helps is welcome. I only have 4 days to continue the test before stopping everything. I will not pay for it if i don’t succeed to start each session in less than 5 mintues.


Email the minions, but some questions in case someone else has a similar set up.

What trainer and firmware are you using?
Or are you using speed + cadence sensors and virtual power?
BTLE or Ant+ or both?
OS version?

Also, this sounds like you don’t have SufSpeed turned on. If you’re using trainer speed, it can be wildly out depending on what gear you’re in and what resistance the trainer is on at the time.

From memory, you change this in the settings section in the workout player

1 Like

Hi. I’m using an Elite Direto X, thus is a direct drive system so the speed is calculated by the HT and sent to the application.
I will look at the firmware, but I succeed to make it works finely with the right speed only once.
Yesterday, in device panel of Systm app on windows, it sees the HT but fail to connect. I switch off the Bluetooth of all other devices around. It succeed to connect one time but with the speed problem so I tried again, and it never succeed again.

The connection is done over Bluetooth. I don’t use any cadence/speed/power sensor except the Direto. I tried on windows 10 and Android 11.

My direct drive trainer also sends speed and it is better to use SufSpeed in the app otherwise mine gives bizarre speeds too.

When you say that you use suffSpeed, what does it means? Is it the virtual device?

Yep SufSpeed is calculated in the SYSTM App. basically the app knows what you weigh and knows what cadence and power you’re putting out and what virtual gradient you’re climbing, so is much more able to calculate a realistic virtual speed. The trainer doesn’t have all that information, only some of it I guess.

@Benjamin_RICHARD I’ve got a Direto X as well, if I connected via Bluetooth I had similar issues. I use an ant+ dongle to connect it to my computer and it works fine so that might work for you

Hi @Benjamin_RICHARD, if you are still having trouble with your connection and you haven’t been in touch with our support team, please submit a request for help here.

Thanks for the help, this is the only way to get valid information :+1:

Hi Cody,
i have open an issue to the support team (#1283158) and they know the problem. They hope to fix the problem. Until this, i have to use virtual speed.