ERG mode issues in Systm

I’ve been experiencing this issue for a few months now - basically my smart trainer doesn’t hold the resistance set in the workout, it is usually much, much lower and tends to be really random (but always much lower than planned) with my power line jumping up and down instead of going more or less straight. This happens on both Bluetooth and ANT+ and on various devices (tried on a laptop and PC).

I use TacX Flux S Smart Trainer and usually (but not always!) a quick calibration in TacX app helps, but this needs to be redone on the following day etc. Also, such an issue has never happened on Zwift or Rouvy, not even once. That’s why I’m guessing the issue is within Systm and not my trainer.

Anyone experiencing similar problems? This is getting frustrating to a point where I’m considering switching to another indoor cycling app for good.

I’ve had problems with a Tacx Flux S and Systm. The issue was recurring drops in power, every 30s or so. This was clearly visible in the power chart after the workout. No issues when using Zwift, RGT or the Tacx app.

I have contacted Wahoo Support in Sep 2022 and they told me they were aware of the issue. They told me that they were looking into this and advised me to use another trainer.

They were going to update me when the issue was fixed, and since I’ve never heard anything back I assume Systm still doesn’t work properly with a Tacx Flux.

I have been using an Elite Suito since, without issues.

Here’s the message Wahoo Support has sent as reply to my issues:

We are currently experiencing issues with the Tacx Flux when connected using Bluetooth and used in ERG mode, exactly as you describe. We haven’t found any other trainer that behaves like this and it also doesn’t occur if you connect using ANT+. Using ANT+ is really the only way around this issue at the moment, but that is only available if you use our MacOS or Windows app, which you can Download Here. You will also need a USB ANT+ dongle to plug into your computer and receive the data from your trainer.

We are still working on a solution to resolve this issue, but it has been quite a while already so I can’t give you any expected timescale.

As I see it you have 3 options at the moment:

  1. Download and use the Windows or MacOS version of SYSTM with a USB ANT+ dongle instead of Bluetooth
  2. Use your Elite Suito for any workouts in SYSTM that you’d like to do in ERG mode
  3. Use SYSTM on your iPad with your Tacx Flux in Level Mode

I’ve tagged this support ticket so you will get notified when we have any update on a fix for this issue.

Another thread on this, but the message above summarises the solutions