Export Data columns

Would it be possible to request that Average Heart Rate and a Date column (separate from time) be included as part of the “export systm data” option? Seems odd that Average HR is not included and a pain that you are unable to sort the CSV by date in Excel.

I would think this is just an update to the backend that generates the CSV file rather than needing an app update.



Why can’t you sort by date? Have you tried saving the file as an excel file instead of a CSV file? I do that immediately and then I can sort by any/every column i choose.

The date column also has the time stamp as part of the same separator so Excel doesn’t recognise it even when changing the format to Date. I have an excel file which references the CSV file and updates the excel automatically so keeps all the formatting etc.

Just needs the time of day moving into another column

1 Like

In excel, use the DATA tab, TEXT TO COLUMNS function. As the delimiter, use SPACE. Make sure you have a blank column to the right free to accept the time.

Now I don’t remember because I do it without thinking about it, but it may leave the old column with a 0:00:00 time after each date (I think it does). If so, just select all the cells, right click, and select FORMAT CELLS. Click on the DATE category and select 03/14/12 option (that is the date format in my version of excel). That will give you just the date remaining in that column which can be sorted.

Please let me know if you have any questions

Thanks I will give it a try.

1 Like

Looks like something is wrong with the csv. It’s just a text file of course. You can open it in notepad.

If you put this in notepad:

Cadence Builds,3/18/2021  17:38:12,00:36:00
Attacker,02/24/2022 17:10:48,00:53:02

save it as test.csv, and open it in excel, the date-time field imports as an actual date-time value, and sorts just fine. Then you don’t need multi-column sorts. The fact that the screen shot shows it as left justified makes it look like it imported as text though. This might happen if the value is quoted or there’s a space after the comma. I may try an export and see later, but it would appear that the csv is malformed.