How to disable/ignore sensors from connecting?

I’ve searched everywhere but couldn’t find anything on this topic.

Basically, my trainer has a cadence sensor, but it sucks, especially above 120rpm. I would like to exclusively use my Wahoo cadence sensor. The problem is that usually, the trainer connects first and Systm app then automatically uses its cadence sensor instead of the real one.

It’s the same thing with HR; the trainer has a relay function that I don’t use, but Systm still uses it instead of my actual HR strap.

This wasn’t much of an issue in Zwift, because it remembered which sensor I’ve used for which function and it would ignore the others. Systm seems to work on the first-come basis, even if I’ve previously disabled the cadence/HR functions for my trainer.

And yes, I could just pick the sensors I want each time, but sometimes I forget until I’m already on the bike and then have to get off and fiddle with the app again.

Is it possible to force Systm to either remember my preferred sensors or prevent it from connecting/using certain ones?

What platform are you on (Windows, Mac, iPhone, Android…)?

I use a Windows machine, typically, and what you are requesting is the behaviour I get (got).

I used a cadence sensor alongside a Kickr Core for ~18 months before upgrading to the Kickr Bike and once I’d set the cadence sensor, once, as the cadence input then it paired that way every time I opened the app in future.
The only thing I might have been doing differently is I “primed” the setup before opening the app, as in I would spin the cranks once before opening the app, that way the cadence sensor and Kickr were both “active” and looking to pair prior to me opening the app.


Yeah. Running SYSTM in Windows 10, the app (almost) always remembers my sensor choices. One thing I do which might help is I always wake up all the sensors before I hit the Start Workout button so the trainer, HRM, and cadence sensors are all awake when the app first starts looking for them.

When I first add sensors, my trainer and sensors can be either ANT+ or BT and in my case for HR and cadence I select ANT+ and pair the trainer via BT. Those sensors show up in the Devices tab and I can select which of those I want to supply what data. For instance, the trainer can be controlled, power, speed, and cadence. I select it only for controlled and power. It then remembers those pairings/selections the next time I do a workout.

Maybe one out of 20 workouts or so, it gets messed up. IDK why, but removing all the sensors and setting them up again straightens it out. I’d rather it didn’t happen, but it only takes a minute or two so it’s NBD in the end.


I’m on Windows.

I usually do that as well (have my HR already blinking and giving the bike a couple of spins to wake the cadence sensor), but for some reason, the trainer is usually first to connect.

Thanks, I’ll try re-adding them again and see if it helps.

I wake up all of them first as well, but in most cases, the trainer connects first and the Systm app then ignores my actual sensors.

You can try changing the sensor connection type. How are your sensors connecting?

I have a Windows PC, too.

I had my trainer, HR, and Cadence sensors all connecting thru BT. It always takes a few seconds for them to connect through BT.

I was getting interference so I switched my HR and Cadence sensors to Ant+. Now they connect immediately while my trainer connects after a few seconds. And like previously suggested, I will turn everything on and start pedaling before I hit play to ensure they are all awake.

So for me with this setup, but separate HR and Cadence sensors always connect first and then my trainer connects and they stay connected correctly every time. Except of course when the trainer decides not to connect and I have to turn it off and on again. But the setup gets remembered from session to session every time.

1 Like

I’m not really sure to be honest. I have an Ant+ dongle on my laptop and the laptop itself has built-in Bluetooth. I’ve never really noticed which connection type is being used.

I’ll try your idea today and move HR/Cadence to Ant and leave the trainer with Bluetooth. Hopefully that does the trick, I’ll let you know.

1 Like

Just letting you know that your idea worked great!

I’ve paired HR/cadence via Ant and trainer itself via Bluetooth. Tried restarting the app a few times and the Ant stuff always paired faster.

I’m marking your answer as the solution, since it does seem to work for now, but really, Wahoo should fix this to something like what Zwift does.

Anyway, thank you for your help, much appreciated.


Fantastic! :+1:

1 Like