KICKR not transmitting power/cadence

Hey everyone,

I already reached out to customer support but I figured I would check to see if anyone here has had this happen.

I was going to do a SYSTM workout this morning and my KICKR connected as usual to the app but neither cadence nor power were transmitting anything. Tried a route on RGT as well and same thing and also tried using the regular Wahoo app. I tried on multiple devices between computer, Apple TV and iPad and also unplugged and plugged in the KICKR multiple times. The LEDs on the KICKR show that it was indeed powered and connected via Bluetooth.

Thanks in advance!

I assume you tried unplugging and replugging the KICKR. Contact Wahoo support. Sounds like you might have a bad radio.

This may not be necessary. I think it is a Systm app issue and not a connectivity issue.

I have the exact thing happen to me at least once a week, often more. All I need to do is close the app and restart it and so far, when I relaunch the program I get everything to load. It’s been going on for at least the last 4-5 months.

It sounded like his problem was across multiple apps: SYSTM, RGT, Wahoo fitness and multiple devices running those apps.