Kickr power and cadence sensor issues

Hi all,

I’ve been using the Kickr for about 8 weeks now. Every now and then when I’m riding in ERG mode, my cadence and/or power readings will skyrocket and then stabilize. It seems like a connection problem. The Kickr stops tracking the sensor readings and can’t stabilize itself back to ERG for a few seconds, and the process continues. The issues have lasted for about 5 minutes. For example, on my last 60 minute 60% FTP ride this morning, power and cadence were spot on the ERG setting and then at 21-26 minutes, the power numbers disengaged from the target and I was hustling until the system regrouped back to normal power.

It’s quite random, but the issue always last about 5 minutes. I’m currently using bluetooth and sit about 6 feet from my router and I bike at a standing desk so the computer basically sits above the Kickr.

Any thoughts?

Sounds irritating. Other than the old standby to fully delete then reinstall SYSTM (which sometimes helps and often doesn’t), my only idea is to contact the minions here.

I have had (but not for quite some time) periods where bluetooth control seems to give up then start up again. Deselecting the trainer control icon then reselecting it used to resolve it when that happened. Maybe worth a shot.

Choose Bluetooth Sensors


Thanks for the help, guys. I’ll try these out and post my findings soon.

1 Like

Although designed to operate without stepping on each other, sometimes Bluetooth and wifi can interfere if the wifi network is using the 2.4GHz band. Does Bluetooth interfere with WiFi? - Electrical Engineering Stack Exchange

Something to consider if your router is very near to your Bluetooth devices.


Suggest, if possible, switching any Wi-Fi to the 5GHz band. Several 2.4 GHz channels will drown out Bluetooth and basically kill it. Also, deselect any automatic channel settings on Wi-Fi as well. They don’t recognize Bluetooth as a legit signal and will stomp on it without a second “thought”.

Sorry for the delay here. I wanted to give this a few tries before responding, but the problem persists! Here’s what I’ve done so far based on everyone’s recommendations.

  1. I switched to 5GHz a few months ago, but still seeing the same tempermental spikes.

  2. In the Devices tab, disconnected then reconnected to Kickr and Rival bluetooth before workout. No luck.

  3. Perform step #2 but wait 15 minutes after connecting Rival and Kickr to bluetooth, no luck.

  4. Pedal as hard as humanly possible out of frustration and in hopes of re-jiggering a connection (see photo). Sadly no luck, but great bonus workout.

Some things I’m going to test over the next couple sessions:

  1. Toggle the trainer controls suggested by @Glen.Coutts

  2. Turn off phone, headphones, basically anything that could interfere with bluetooth.

Might be worth noting I use a Surface-Laptop 11th Gen, i7-1185G7 @ 3.00 GHz processor and 32GB. I’m not a computer guy but someone else might know if this matters.


1 Like

May also want to try the tried and true and often successful— uninstall the app completely and reinstall (making sure you have the most current version too). @AkaPete suggested this above as well as to connect directly with support here

1 Like

Yes, thanks Glen. I recall trying that initially too, but let me try my luck again

1 Like

One other suggestion: make sure KICKR firmware is up to date and that Windows is up to date. You use the Wahoo Fitness app for the KICKR firmware. Just make sure to completely quit the app when your do one to avoid stealing the Bluetooth signal from SYSTM.

I’ve experienced similar sounding issues with my 2017 KICKR. I train in a conservatory (not ideal for temperature control, I know!) and what I’ve found is that if the light level changes significantly (e.g. the sun goes behind or comes out of a cloud) my KICKR loses connection in a similar way to what you are describing.

To mitigate this I either train at a time I know the light levels won’t be changing too much (early morning, late evening) or I shield the KICKR with some cardboard (I believe there is a shiny part of the flywheel with some IR markings used to measure speed that get messed up when the light level changes). I don’t know if newer models have this same issue but I find it’s manageable so long as you are aware of it!

1 Like

Me again. This issue is still persisting after seven (7) months. I’m losing patience with this incredibly expensive “efficient” trainer. No user suggestions have solved this. I removed and reinstall the program more times than I can count, tried it on another computer, adjusted wifi settings, toggled bluetooth connections, trained in blinding sun, total darkness, early monring, late night. I’m too stubborn to accept that this just happens every few spins and I can’t be the only one with this problem. Someone please help. It’s not long before I give up on Wahoo.

Are all of your drivers up-to-date? I would assume so as the Surface updates through Windows Update automatically, but it’s worth checking.

I love Surface laptops, but one of the problems with any tablet based system can be the condensed structure of the mainboard and components.
You can get a Bluetooth dongle for ~£9-10, so it’s not a terribly expensive purchase to “test”, but I would suggest purchasing something like the TP-Link gen5 Bluetooth dongle and giving that a try instead.

I use several computers with my Kickr and they tend to be fairly consistently good, but I do have a very signal-noisy house and some of them have very occasional dropouts (very occasional, nothing like what you’re seeing).
With the takeover of RGT I’ve been using that more recently and to get a better experience in that I brought an old gaming PC into my cycling den. That machine didn’t have a built-in Bluetooth chipset, so I bought the TP-Link dongle and the difference in pick-up connection speed and then consistency over even my most reliable built-in system has been tangible.

Amazon UK link for dongle

This would kill me too @maxkev. I LOVE tech when it works but it can be soooo incredibly frustrating when it doesn’t :angry: :right_anger_bubble:

Maybe this goes without saying as it was suggested before but have you reached out to the minions for support at all?

When you’ve tried everything you (and others) can think of and the issue is still not resolved, it might even be the trainer itself that is glitching. In any case, you really ought to connect with the support folks if you haven’t already. Here is the link to them again:

@maxkev I have seen some weird things with Bluetooth. If I have my AirPods in the pain cave and I then put on my heart rate strap my Wahoo Headwind will crank up to a high speed. I found putting on the AirPods 1st before connecting the HRM and the problem goes away.

For cadence I actually use a separate cadence sensor and don’t rely on the trainer. I initially did that because I had a sensor which I use for outside rides but I also found that it is beneficial when doing cadence drills where RPM is over 130. The Kickr should work so either it is faulty as respect cadence or you are getting some sort of interference. Anyways the separate sensor might be an alternative course of action to try.

I hope you are able to resolve the issue!

Is your laptop close enough to the trainer? Some people are using an extender thing for the laptop to better pick up the signal.

Those spikes look pretty regular…what happens if you unplug your fan?

And is your laptop plugged in to power or running on battery? Have you got it sent to high performance battery use? If not, it might be pinging the trainer at less frequent intervals.

Have you tried an ant+ dongle. I could never get a reliable connection over Bluetooth on my PC with old Sufferfest app, back then ant+ was the recommended resolution. Do you have an iOS or Android phone or tablet you can install SYSTM on to test whether the BT issue is your PC and or Windows?

I’ve NEVER found a pulse based cadence sensor to be anywhere near as reliable as a crank arm based one. I know my cadence rates and I find that my Quarq based SRAM crank based power meter works great as the crank based cadence is built-in. I double down on getting a crank based cadence sensor. Both Wahoo and Garmin make great ones. They are ‘double sided’ and support ANT+ as well as BTLE. I would spend the money for one before giving up on SYSTM/RGT.

@jmckenzieKOS Yup - agreed. I have the Wahoo cadence sensor and it works well.

I have a Garmin sensor. Sadly, it doesn’t fit on my Grevil very well. However, the crank based power meter does use rotational activity to provide cadence unlike the KICKR or any other ‘smart’ trainer which uses pulse based activity. So, having the cadence sensor was unnecessary duplication.