Level Mode Not Working in both SystmX & RGT

Hi all. I’m having some issues with getting level mode to work correctly & have been working this through with both Wahoo support and Elite. Any ideas welcome as we seem to have ground to a halt in progress,…
I’m running off my iPad 7th gen ios15.6.1
I have an Elite Drivo 1 linked up via bluetooth
In SystmX ERG mode works a dream with changes reflected after 5-7secs
I recently downloaded RGT with the intention that i would complete some group rides etc & noticed that hills were not being reflected in changing difficulty on the trainer

  • I followed the bluetooth re-connection advise as per https://support.wahoofitness.com/hc/en-us/articles/4402564853138-Connect-your-Trainer-Compatibility-Tool- = it connects to bluetooth with no issues
  • ERG mode working however level mode is not working in RGT or SystmX
  • I did manage to get level mode working in SystmX by going into a workout, connecting the Drivo, changing it to level mode (however the trainer remains in ERG mode at this point), disconnecting the Drivo, reconnecting the Drivo = level mode works at level 0. I could demonstrate this by keeping the cadence constant (80rpm) and going thru the gears with the power needed increasing at each gear. However I was not able to change from level 0 using the same method of switching off and back on again
  • Trying the same method in RGT was not successful. I could only use ERG mode
  • Level mode tested within the Elite etraining app = working as expected. On this basis Elite say this is an app issue??
  • I tried my old wheel on CycleOps (now Saris) M2 smart trainer and that works a treat in both ERG/Level mode (not great for those hills/high power sprints tho - the reason to going to a Drivo). This suggests maybe the Elite trainer is at fault not the app??
    = A quick test of Zwift and both level/ERG mode works with hill difficulty being reflected as expected
  • FYI my 4DP score I am using was from the M2 trainer. Trying this now on the Elite in level mode I just spin out as changing the level mode up a notch or 2 makes no change to the power
  • There is mention in outside forums that the Elite Direto may have a similar issue however no mention as to whether it was ever resolved
    Any thoughts welcome at this point (other than buy a new trainer please - haha) as this is becoming more than a nuisance
    Thanks for looking
1 Like

Is it at all possible that one or another app has stolen the control from RGT or SYSTM? Either on your mobile device, your phone or computer?

I say that because I’ve had an issue where I had used Zwift and it was fine. Closed Zwift and was unable to get SYSTM to control the trainer even though the green lights were lit and it appeared to be connected.

My resolution was to turn off Bluetooth on both my phone and my computer (where the SYSTM app is) then toggle Bluetooth back on only for my computer, connect to SYSTM and all was good. Then I could toggle Bluetooth back on for my phone.

Worth a shot at least.

1 Like

Thanks Glen. I have switched Bluetooth on & off so many times now it’s unreal. Knocking off all other Bluetooth devices making sure alm other apps r closed etc. Today I even loaded SystmX onto my android phone and tried that way too & still no luck with level mode