No Strava upload after update

I’ve been uploading automatically and successfully since the start of SYSTM (and with SUF, too). Today, I got an update to 7.15.0. Rode The Cure. Not uploaded to Strava - website or mobile. I checked and the Strava upload is turned on in SYSTM. Anyone else?

Edit: Checked in Strava and the SYSTM connection is ON.


Yep. Finished a workout about 40 minutes ago and it hasn’t uploaded to Strava yet. I have not had an issue with uploads previously. Permissions are properly set in SYSTM and Strava.


It is not updating today to either Strava or Garmin Connect for me, and no error email that is typical when Strava rejects an upload.

Same. Blender didn’t upload to Strava or Healthfit apps. It did record within the SYSTM app though it terrified me by sticking on “syncing.” I’m on an iPad Air running iOS 15.1 (19B74)

Same here. My workouts didn’t upload to strava and all the connections are correct and I even tried to do an additional share. Must be a problem with Systm today.

Same here. It’s happened before. It may be a Strava issue rather than SYSTM.

@David.McQuillen.KoS any update on a fix for this? Thank you, Sir.

Same here. It syncs with SYSTM apps on different devices (e.g. ipad and phone), but not Garmin or STRAVA.

Yep more of the same

Can I ask if your workouts have synced to the calendar ok in Systm?

Mine is showing as orange in the calendar, which is a first, rather than the usual green (or grey).
No sync to Strava or Garmin

Logged out / in and deleted / reinstalled the app.

Calendar sync but no upload to TrainingPeaks

I had this same issue on a ride this afternoon.

Same, shows complete in calendar but not uploading yet normally uploads a few seconds on completion for me. Sync’s a few times and shared a few times to Strava but no joy. Finished the ride a few hours ago - Rookie, video was buffering too.

Mine has just uploaded! Hopefully everyone else’s will soon too! :+1:t3:

I received the normal completion email, and today’s Blender workout is showing green in SYSTM, but I also have not seen it uploaded to Strava.

Yeah tried sharing a few times but no joy.

Luckily I double recorded using my Edge 530 and this has uploaded to Strava, and ultimately

I completely lost two workouts a couple of weeks back that failed to sync altogether and have been double recording since.

Hi @giorgitd - Our Dev Team is aware of the issue and is currently working on a resolution - we’re so sorry for the frustration and delay of your working sharing! I’ll post an update to you once we have it resolved - thanks!


TrainingPeaks just updated with my Blender share, too

1 Like

Mine too now after manually sharing again :+1:

1 Like