Workout sharing issue

I just finished The Rookie session today (I was suffered!)

I am using SUF on iPad, after workout I clicked save and usually it automatically uploaded to Strava/TP/Garmin. But it didn’t, it seems my connection had issue because when I manually share to Strava it said queued. After restore my connection, I click again share, and it said successful but still not uploaded to Strava.

I already tried, logout, disconnect strava, connect again, and then manually share the workout. But still not uploaded until now

Need help.

I am unable to upload a ride without having some sort of comment on my workout. I am using PC but could be a similar issue. That said I am new so I could be doing something wrong.

Email the minions.

Thanks! email Minions and it solved my problem

So it didn’t save properly in my device.

it appears as if the workout file didn’t save properly on our server - and that is why the file was not able to share. Please try these steps:

go to your passport in the app and open the workout file.
make a comment in the notes section - but please do not use any special characters
save your changes

This should prompt the file to resave - and then it will share with the Strava/TP/Garmin