Planned workout doesnt work

After the latest update I cant use planned workouts anylonger, it says “sync failed”. I have a Rival watch. I have reauthorized Trainingpeaks. Anyone know what to do?

1 Like

@V.J Are you referring the latest Element Companion App update? Have you tried to delete and reinstall?

Yes the latest update. I have deleted and reinstalled the app, disconnected and connected the watch to the phone etc etc.


I also have the same problem. The support replied to me that they are very sorry and wait for a new update.

1 Like

An update to the element app arrived yesterday. Structured workouts won’t load again, it’s gotten even worse. If I choose training on a bicycle, it is not on the list at all.

Seems to be an issue specifically with the Rival. I am also not able to transfer my Trainingpeaks workouts. The workout preview does not show an average stress line anymore, also the intensity factor is completely wrong (IF=0.01). Sync can also not be manually triggered on the watch anymore.

And I thought I had a sudden performance boost :rofl:

You can’t load workouts into Element Bolt either.

I have just tried it with my Roam V1 on the latest firmware: Both TrainingPeaks and Wahoo default workouts could be successfully selected and transferred.

On the other hand, the Rival gives the error “There was an error loading the workout on ELEMNT” both for TP and Wahoo workouts.

I have Element Bolt V1 and I still can’t load structured workouts.

This morning my structured workout from TrainingPeaks appeared on the Rival. Has someone been pressing buttons :ok_hand:

The Minions work in mysterious ways. A little birdie tells me yes.

Lucky you! Still dont work for me :weary:

still doesn’t work for me neither

I am running the latest Companion App on the latest iOS Build. To be fair I have been disconnecting and authorising the TrainingPeaks connection on a daily basis

Same issue here on element watch, no TP workouts uploaded for 3 weeks. Have reinstalled and updated muktiple times

Typical. This morning iOS App Store prompted a new update to Elemnt Companion App (1.72.1). After update I was prompted to reauthorise with TrainingPeaks and now I have lost all workouts again!

I solved the problem! Just sold my Rival and bought a Garmin and it works perfect to import workouts. Sad i had to do it but i have had a lot of issues with my Rival…

1 Like