Ride not syncing despite no connection issues

Hi. I’m trialling the new SYSTM platform and have 13 days to decide to stick with Zwift or move across. I went for one of the prorides and enjoyed the experience. The problem is that it has not synced anywhere. The ‘syncing’ overlay is stuck on the ride in my calendar. I can see the ride with a green tick for 1hr10mins, so it is there… but won’t sync anywhere. Syncing these onto strava is gonna be a make or break for me (even if that’s sad!), and I’m already getting my head around not having elevation gains to show on strava versus the benefit of better (?) training plans and other workouts (strength / core etc)… I submitted a request already yesterday evening but have heard nothing back… can anyone help with this? I’ve also completed the 15 min basic yoga plan, as much out of interest and to see if it would sync - it did, no problems, so there it seems this one activity is stuck - any way to unstick it? Otherwise it’s gonna be on my calendar constantly trying to sync ??)

I assume you’ve already authorized Strava to sync. If not go to SYSTM Settings and click on Authorized Apps and follow the process.

Once that’s done, all future workouts should sync. If they don’t, contact support and they can help you.

If you want to sync an older workout or one that just didn’t sync for some reason, try this (can’t guarantee it will work, but it has for me). Go to the workout on the calendar. Click the 3 bars next to edit which should bring up the Share button. Click it. Make sure that share with strava is on and click Share.

I hope that helps.

Thanks for the reply AKAPete. Yup - everything is authorised and two other ‘dummy’ SYSTM activities (that I ran as sync tests) have synced across no problem, including to Strava. The 3 bar solution won’t work as a manual workaround either as the syncing status has shaded out the activity and the 3 bars is not appearing. So I can’t share that way either. I’m hoping Support can help either through the support ticket raised or through the forum here… I think I like what I see with SYSTM and consider it a genuine alternative to Zwift, but even if the first ride itself was enjoyable, the syncing issue is a bit of a downer… appreciate the reply. thanks

‘Syncing’ in the Calendar refers to SYSTM syncing. I get my workouts on Strava before Calendar shows them green-ticked. Have you tried to log out and then log in back again in the app?
There is a chance that your app is stuck and does not update itself. Logging out and back in should help with this. It will not help with Strava, yet it would allow you to resend workout to Strava again.

Yes, tried this. Logged out and back in, and have even unistalled and reinstalled the SYSTM app on download in windows. The SYSTM sync in calendar is permanently stuck and simlpy states ‘Pending’. It’s a mystery…

Hi, I just want to report that I also have this issue.
This evening, I tried for the first time the new app (I used Sufferfest app in the last 3 years) and after I finished the workout (getting away with it) I noticed that I couldn’t access the results (it is shown with the “sync pending” icon).
I tried the following:

  • logout/login,
  • disconnect/reconnect all third apps (Garmin, Strava and Trainingpeaks),
  • added specific roules to firewall to grant access in and out the internet for the app.
    None of those actions had a result. Any advice? Thanks.

This is very odd, have you raised a ticket with the Minions? The log out and back in trick works for most who see this issue. Only other thought I have is, are you on a Windows machine and is it updated? Sorry I can’t offer more suggestions. I’ve only had this issue once and all I did was switch to the Calendar screen and back to Home screen and voila, all sync’d

Raised a ticket with the support team who’ve been great at keeping me up to date. Apparently it is a bug they are aware of and working on - so none of the obvious options I, and glan88, have tried would have worked (it’s got nothing to do with refreshing the app, or even reinstalling it). Thankfully other rides and workouts have synced…

Glad to know that its a known bug. I raised two tickets thus far with no response.

I am having exactly the same issue. Just one activity on the 25th October. It’s driving me nuts. I cannot do anything with it and I now have a feeling it’s the reason why I cannot view my subsequent activities on Wahoo Systm, or get my ftp data. The activity also never synced with Strava whereas all others have. I raised a ticket on the 7th November and to date have had no fix from their tech support despite chasing up several times. I’m beginning to feel quite jaded with it, especially as I’m paying for the privilege.

I also started experiencing the syncing issue. My problem is the workout starts and works perfectly, although once I save the workout it doesn’t sync in the SYSTM app - no green tick. So I have to complete the ride manually, but that only gives the green tick with no data. I use my iPhone 11. 4 workouts now sadly not synced. Ticket raised, response received and waiting on solution.

I’ve tried the log out, log in a few times with no success. Switched phone off and on, reset my wifi…. No luck. I’m scared to uninstall app, as I do not want to lose my history.

Uninstalling and reinstalling resolved the problem when I had the issue a few weeks ago. Your previously saved workouts and history will not be lost - these are saved on the Wahoo servers and not on your device.

2 Likes

Thanks!! That fixed it.

2 Likes

When I’ve had that problem, usually just fully quitting the app and restarting it works too. That’s easier than deinstalling/reinstalling.

1 Like

Same issue here. Ride won’t sync and I have good internet connection.

I am really torn about Systm. Overall I like it. I am finding some good workouts. But, I have more issues with this software than the next ten I use combined. I’m not sure it’s worth the aggravation. If it doesn’t improve when my annual subscription renewal time comes around, I will likely explore other options.

BTW - I have stopped reaching out to support. I’m tired of beating a dead horse.

1 Like

This issue persists for me, i get this message every couple of weeks where the sync is pending on my iPhone. It has not been related to my internet connection, and it is not related to authorising Strava or Garmin (checked all this). Sometimes it resolves itself after 5-10 minutes. Sometimes i close the app and re-open (this doesn’t always do it). Somewhat annoying.