Reviewing Systm and todays ride is not syncing

I did the Full Frontal and another ride this AM, I have syncing with Strava active. Home screen and Calendar views show Sync Pending. Ride was about 5 hours ago, assuming this is not normal.

Second question: should the rides be auto syncing with element, same user name/ password?



Should all be fixed now. Synch should happen now – if you don’t see it, then close/restart the app and it should all kick over. Again, sorry for the trouble everyone.


Same problem. Last two rides stuck on sync pending. After waiting for ages tried force closing & restarting app. Rides synced but only about 2/3 of each with note that activity was recovered. Very frustrating. Any advice gratefully received.

Hey @dj13r ,
Sorry for your frustration. Please submit a support ticket and you will get sorted out:


This happened to me yesterday and today

You can see it says etc pending. Through the window transparency you can see a green checkmark and a time of 5:33. If I close and reopen the app it says recovered and shows 5:33

Any update? My ride didn’t sync on Monday either.

I rode today and it was the same

Was this resolved for you?

I had the “Synch pending” problem both yesterday and today. After about 10 minutes of waiting, I tried to logout/login yesterday - which did not not resolve the problem. I then tried to shutdown and restart the app on both days, and this caused only the first few minutes of the session to be recovered (this is on iPadOS)…

I may have to resort to removing and reinstalling the app (not a big deal, except for the 70 videos already downloaded), hoping it’ll fix the problem.

@David.McQuillen.KoS , do you know if there are any backend issues these days?


I’ve had the same problem for the past week. I thought that it was because I was out of town with a poor internet connection, but it happened today at home this morning. The application will say “sync pending” for a few hours and when i close out and restart I only get a few minutes of the workout showing. For example, today I did the Bat it the application says I only did it for a little over 5 minutes when it is a 59:37 workout.

I tried to run a 5 minute intro video (from the A Week With category), and had the same problem again.

I ended up removing then reinstalling the app on my iPad, and when I ran another intros video, it saved properly. This makes me think that some app glitch occurred on my iPad, rather than this being a backend problem. Note that this “should” not be related to storage capacity, as I had 46gb free prior to removing the app.

After having reinstalled the app, I noticed that the session was also properly sent to Training Peaks - this had stopped working for me about 8-9 days ago (after I had re-authorized TP as prescribed a few weeks ago).

Are you running on an iOS device?


I am running SYSTM on my iPad. Will try reinstalling the app tonight and see if it works tomorrow.

I received a reply from Wahoo support, confirming that theirs is a known but intermittent problem with the SYSTM app on iOS, and that this is the only known solution. They’re looking into a fix.
They recommend to reboot your device after deleting the app before reinstalling it. Another suggestion was to shutdown the app between workouts.

Be aware that while you’ll not lose any workout history or planned workouts, you will need to reconfigure your Bluetooth devices and redownload the videos.


The Wahoo cloud is a mess at the moment:

  • RGT workouts are shown in the ELEMNT app, but not in SYSTM
  • Rival workouts are labeled as “unknown” in SYSTM
  • RGT workouts are categorized as “unknown” in ELEMNT app
  • ELEMNT app shows red status icons on workouts failing to uploud to Wahoo Cloud

These are just a few examples I faced the last 2 weeks.