Completed RGT Ride Not Syncing to SYSTM Calendar

Today, I rode Dunoon. It synced with Strava, but not with SYSTM or the Wahoo app. Anyone else have this issue?

I think this was my first RGT ride since the upgrade.

Mine took a bit this morning before it appeared in SYSTM and Wahoo. How long has it been?

A little over an hour.

Mine too. I rode yesterday on RGT but until now its not showing up in SYSTM Calendar.

Same here for Tuesday’s ride. Today’s showed pretty fast thou.

Only difference was that Tuesday’s was a free ride and today’s was a workout. I wonder if that makes any difference.

Edit: I used Android app on Tuesday and Windows app today. I recall on Tuesday the app crashed at the end of the ride and FPS were extremely low even in low res.

My RGT ride has never appeared. On Sunday, I submitted a ticket. I am still waiting on a resolution. In a different matter, my SYSTM workout this morning is not syncing. I had this problem earlier in the month and thought it was resolved, but I guess not.

Are your account login emails different?


Logins for SYSTM and RGT are the same.

Ride today was in SYSTM, but it never synced. I waited 1.5 hours. I tried closing the app, logging out and back in, shutting down the iPad and none of these worked. I finally just deleted and reinstalled the app. This got it out of the sync pending mode, but no data recovered.

1 Like

I have the same issue. Rode today training, ‘sync pending’ for last 2 hours. Restar, reinstall didn’t work.

Looks like a server is down. My ride this morning didn’t sync at all. Hopefully comes back online soon

Hey guys - sorry for the synching issues. We’re looking into an issue on our back-end. If you drop us a ticket we’ll look into it right away - we might be able to manually synch it for you:

Should all be fixed now. Synch should happen now – if you don’t see it, then close/restart the app and it should all kick over. Again, sorry for the trouble everyone.

During the interim, I deleted and reinstalled the app. I assume my workout data is gone. Is this correct?

Drop a line to our customer service team and they might be able to retrieve it for you.


Thanks for the response. I have submitted a support ticket.

1 Like