Share more info on app changes?

From posts on this forum and others it’s obvious many of us who had no issues connecting our trainers, power meters, etc., to the Sufferfest app now have problems connecting to the SYSTM app. In my case a Stages SB20 that worked perfectly with the Sufferfest iOS app does not work with the SYSTM iOS app.

I had an outstanding conversation with a KOS minion where we tried all sorts of work arounds. The conversation concluded with “it just doesn’t work,” and a suggestion to use a laptop with an ANT+ dongle. Not a good solution in my case.

While no company can promise a fix, and I get that coding and testing features in an app takes time, it would be nice to know that something either is or is not being done.

So, could our community get some sort of routinely updated list of app fixes, by OS, that are in the backlog? For example, “we know there is an issue with SB20’s and the iOS app. A fix is being worked.” Or, “we know there is an issue with SB20’s and the iOS app, but that is not something we plan to fix.”

A little peace of mind would help us focus our suffering on the things that really matter, like Thin Air or Nine Hammers.


This is standard operating procedure for the hardware/software industry.

Some really stupid questions:

  1. Does the device show on the Bluetooth selection screen?
  2. Does the device show on the Device Selector screen on SYSTM?

If the former is false, it is an issue with IOS (15 did some really strange things for BTLE 4.0) and needs to be addressed to Apple
If it is the latter, please check there are NO other programs that are trying to take control of BTLE devices (again this is somet that happened with IOS 15 from what I understand).
Also, are you using ANY other BTLE devices while you try to connect to the SB20? Headphones and speakers are notorious for causing issues under IOS AND 'Droid.

I’ve been having the same problem, Systm works fine on my main machine, a windows 10 laptop, no problems what so ever, but I can’t get it to work on my iPhone 8, my Neo appears in the devices bluetooth selection screen, but system just refuses to connect, I was on 14.8 this morning, but upgraded to 15.0.1 this morning, and no difference, I had no issue with SF and no devices have been added

Those are great questions, thanks for helping and asking. So I did some experimenting.

In my case, the device shows on the Bluetooth selection screen. The device also shows on the device selector screen in SYSTM. No other BTLE devices being used or connected. I even deleted the Stages Link app to make sure nothing was fighting for ownership of the device.

For all, had another conversation with my KOS minion, can’t say enough good stuff about these guys.

I have a Stages SB20 and I was able to get mine to work by pairing power and cadence to the left crank arm power meter. I left bike/trainer control paired to the bike itself and everything (e.g. ERG) “seems” to be working…