Can't connect bluetooth devices since updating to macOS Ventura

Once I updated to macOS Ventura, my bluetooth device’s don’t connect anymore through the Wahoo SYSTM app. They do connect through other device’s. Just not the MacBook that i am using. Is anyone else experiencing this problem and does anyone know how to fix it? I tried to reinstall the app already but without any luck.

1 Like

I’ll test this right away.

Edit: I can’t test it yet, cuz I don’t have Ventura yet. Sorry @Jasper

Are you referring to MacOS 13? If so, it’s on a limited beta and not available as a GA yet. This needs to be filed as a Bug Report through support.

I’ve been on Ventura since the initial public release and Bluetooth has worked fine. Wonder if there’s some permissions that need setting somewhere within MacOS?!

What number version is Ventura? I thought that was the code name for 13 and it is in limited beta release.

It is 13 and it’s been on public beta since about June/July.

Edit: apologies, just realised I missed the word beta in my last reply! :slight_smile:

1 Like

I was wondering something like this too.

OK. It’s time to address issues raised with MacOSX13. However, work to address them shouldn’t start until it goes General Availability because things do change in a project that big between Beta and Release (and yes, I’ve been the victim more than once of a ‘fix’ not being present in the Release but was in the Beta that caused a large project to stop compiling and running).

On the flip side, if things are picked up early (part of the reason for beta releases) it can save massive headaches when it gets released to the public at large!

1 Like

Very true. Just lining them up for the release always helps.

1 Like

Any update on this? I updated to MacOS Ventura 13.0 today and I‘ve lost Bluetooth :cry:

Edit: Removed the devices restarted everything and it came back. All good so far :grinning:


Any update on this? I am having the same problem I have MAC OS Big Sur 11.7.
Cannot get any bluetooth to connect to the SYSTM app.

… moments later. I tried using the app on my phone. Blue tooth did connect but, I was unable to adjust the FTP in the settings tab. I would change it to 200% but, the system would not change. The display and the feel remained at only 100%.

Really frustrated since I just bought 15 months of the service.
Thank you

I’m on Ventura now and have no issues connecting BTLE.

What are you trying to connect? That is, what trainer and/or what sensors are you finding are not connecting?

I have no problems connecting a Kickr '18 with a Climb and a Tickr 2 HRM

Hi. Thanks for responding. none of my bluetooth items connect. SYSTM finds them when searching but, just spins when trying to connect to them. My mac bluetooth is working fine and says it is connected to the KickR, but, the application is not showing connected.

1 Like

So, sorry if you’ve tried this before but it’s worth trying if not.

  1. Toggle your mac’s Bluetooth off, then on again. Then try reconnecting stuff
  2. Restart your Mac and try again.
  3. Uninstall SYSTM, and reinstall. A fresh install has resolved a few things for me when they’ve gone awry.

Also, make sure you’ve got all the latest firmware for your Kickr and all peripherals.

You should also check that SYSTM (and RGT) have permissions to access Bluetooth - that might have been reset in the update to the new MacOS version.

System Preferences → Security and Privacy → Privacy → Bluetooth


That was a hopeful comment. Thank you but, my system privacy settings are allowing SYSTM bluetooth.

My SYSTEM app on my phone will connect, but, not my macbook air.

1 Like

Also curious, what version of the Kickr do you have? I ask because the pre: '18 versions only allow one connection so it might be possible that you need to turn bluetooth OFF on your phone, until SYSTM has connected on your MacBook Air. It probably wouldn’t hurt to try that anyway.

Thank you. It is strange because I used this same Kickr and my macbook last year with my SYSTM subscription. Now as I re-up my subscription, it wont connect.

Hi… thank you for these ideas. I did as you suggested… I get the same response… Just spinning as it tries to connect and never does connect.