Spindown fail in Systm android app

Hi all,

New Kickr Snap owner and Systm user here. Overall enjoying the trainer and the app experience, and things seem to work most of the time but wanted to ask if anyone else is having issues with the Spindown inside the systm app? I’m on a pixel 4a, latest android, latest app version, latest firmware on the snap. When I use the wahoo app, I can always connect and my spindown always works fine. However, inside the system app it almost never works. As soon as the spindown screen opens it just fails. The retry button does nothing. If I disconnect and reconnect a few times sometimes it eventually works but I usually give up and just use the wahoo app instead.

I contacted support and it took 3 volleys of emails to even get them to acknowledge that there is a spindown feature in the app. Once they admitted it was there, they refused to believe that it wasn’t working and just buried me in links to the usual troubleshooting steps that I’ve already tried. I ultimately gave up on arguing with them and closed the ticket. I have a feeling nothing was ever reported to their dev team as a bug so not expecting it to get fixed any time soon.

The fact that it always works in the wahoo app tells me that my device, connection, process etc are all fine and it’s just a bug in the systm app. I wanted to see if anyone else has this same experience with the systm app and spindowns never working? It’s not the end of the world to switch apps but since I’m on the Snap I’m spinning down every ride for consistency so it’s more than just an occasional annoyance.



I’ve had similar lack of success in the iOS SYSTM app. I use a Kickr ‘18 and have (almost) given up on trying SYSTM for the spin down cuz the WFA always seems to work. I’m pretty sure I reported it as a bug/issue but will do so again cuz, why not?

1 Like

Alright, glad I’m not crazy. Oddly enough, it just worked 2nd try today but that’s the first time it’s succeeded in less than 3 tries and the first time in 4 or 5 rides it’s worked at all. Maybe a few more reports about it will get it moved up their issue tracker for someone to look into. Seems like a timeout issue and hopefully an easy fix once someone actually looks at it.


I often have trouble just getting it to pair to the Kickr and usually just give up there but it’s been a while so I will def try again soon based on your recent “success”.