System App formatting broken

This evening when trying to do a cycling workout the title, description and other text is all on top of each other and the start button is covered by the workout graph. Any ideas? Unusable in its current state! Worked Ok until 7pm, 29th Jan 2022, then useless.

iPad (5th generation) iOS 14.3

Thanks in advance

1 Like

Another example:


That ain’t right. I’m on iPhone and Mac and have not seen that.

Couple things to try. Completely shut down app then reopen. Log out then back in. Delete app and reinstall. If none of these work then contact the minions at


:+1: Cheers. Have tried that though :disappointed:

1 Like

Silly question - have you tried both in landscape and portrait orientations?
I’ve no problems on my iPad….


1 Like

Ha ha, yes.

Actually I have now found a solution. I had to update the IOS on the Ipad to 15.3. Methinks Wahoo haven’t done their beta testing properly…


Same here. Submitted a ticket referencing this - nice to know I’m not alone but still…

1 Like

I logged it as a bug, so perhaps it’ll change, but with updated ios it’s fine. Annoying that I has to update but fortunately only 1 legacy app is now causing issues. You may have more riding on keeping the old IOS version…

Are you saying that it is fixed with IOS 15.3?

I’m not having that sort of luck. It is fine on my phone but not the mini IPad.

Yeah. 15.3 and it’s back to normal.

So far…

1 Like

I guess I’ll keep my fingers crossed

The best tech support answer was to delete and reload. I’ve done this twice now and still having this issue. Had to use my phone to do today’s session - which was terrible as the phone based app cut out my Spotify feed.

That did, in the end, fix the problem. I got a false indicator about the current iOS for the pad and once I updated everything worked. Thanks again

Good stuff. Pain and suffering awaits! Mine has been happy ever since the IOS upgrade.