Tacx Flux S

Help! My husband just got the Tacx flux s, I have a wahoo kickr core. His trainer ( the flux) can’t seem to figure out the power he is literally all over the place and don’t even get me started on cadence. Trying to figure out what to do so he doesn’t loose motivation. Not sure if this matters but we also live in Italy. Thank you !!!

I use a Tacx flux s as well for more than a year now.
The power data are consistent and seem to be in the same order of magnitude than the data from my power meter on the outside bike. (I yet haven’t put that bike on the trainer to compare the data side by side).
The cadence data are of poor quality, I use a dedicated cadence sensor on the crank shaft instead. (But I actually never figured out how the trainer would measure the cadence anyway, since there is the gearing between the pedals and the rear hub). Does it work on the kickr?

1 Like

I don’t think erg mode is really working because say he’s supposed to be at 170watts the trainer will let him go to line 279watts does that make sense 🤷🏽

Your best bet is to contact the support minions. They will be able to look at your specific situation and set up. They might miss requests here on the forum.

You can reach them here:


1 Like

I suppose he is shifting to small gear when he pushes only 170 W. If I’m on the large chain ring and ride at a cadence of 90-100, I will always get more than 250W. But otherwise my Flux S is working really well.

1 Like

and you didn’t set it up specially or anything? Are you using bluetooth?

No, no special setup was needed.
I actually use an old laptop with bluethoop and ant+ dongle. Normally, I connect via ant+.
Yesterday, the connection with the external screen had some problems, thus I was using my new (windows) laptop. Systm was already installed, but never connected to any devices. I just worked out of the box with bluetooh, no problems what soever, neither heart rate monitor, Tacx in ERG mode, cadence sensor.

1 Like

Another Flux S user here for the past 14mths with no issues.

I occasionally manage to confuse it with ant & BT connections at the same time, but that’s my fault switching between my old laptop and phone.

Mine isn’t able to cope with the the full range of power control in erg across every workout, without sometimes changing gear, but I know that starting in Small front and 3 down at back will do me for recovery sections up to MAP intervals. For AC & NM, I’ll need to change a gear or 2.

It does make a half decent stab at cadence, but you’re better off getting a separate sensor as it certainly can’t record higher than 120rpm.
(The software watches the power spikes from your downstrokes to calculate cadence, not perfect but passable)

Overall, been good value for me.


I had similar issues with my Flux but still with the old SUF app…
I could solve the problem with an ant dongle on my airmac. Didn’t work with BT but perfectly with ANT.

First - you might need to make sure all the apps and programmes are up to date first. (Even to the extent of deleting and reinstalling) on everything you both use - lap top/ phone & tacx flux & wahoo.
Also when you use your Tacx app to check /update the trainer - disconnect and turn off bluetooth on phone afterwards! Otherwise confusion arises :slight_smile:

I’ve had some shaky bluetooth experiences (probabaly old lap top) and am now using an ANT dongle (USB stick in lap top) that has proved stable. And I always load down the sessions before I start - you should be able to stream but if your Wifi is slow/shaky this could also cause problems.

My husband uses a non-smart trainer with BT and if he starts pedalling before my HRM has been found that also causes confusion.
Hope you get it sorted - it does seem like a faff at times - but it is worth it!

1 Like

For reference

I guess my question is how normal is this? I wasn’t even pedaling at anything other than a casual pace.

I will check tonight, what readings I get if I set the target to 67 W and will keep you updated

Just looking at the photo - no its not “normal” . I also have recovery watts around 65W and my Tacx hits them well enough (60-70W) . One thing to check is if you are in your lowest gear - because if you are in a too high a gear I’m not sure the trainer can go that low.

1 Like

Connect the Tacx via ANT+ not Bluetooth. There is an issue with Bluetooth at the moment. Also try running in the small chain ring and the slightly larger side of the middle of the cassette. If your recovery power needs to be below 90 watts, maybe just run it in the biggest cog on the back.

Those big drop outs are typically a Bluetooth issue.

The cadence sensor on the Flux is OK but having a dedicated one is better. The Flux calculates rather than measures cadence

I just checked my setup. If ride with a 39 (yes, I have three chain rings on this road bike) / 23 gearing at a cadence of 60 rpm, I won’t get a power output of less than 80 Watts.
If I switch to the smallest chain ring (30), it hits the target of 67 Watt pretty well.
So, if I would use the more common Ultegra 52/36 with 10x cassette 28-11, and I would switch to 36/28 (which is the smallest gear in this setup), I would not get less than 60 Watts at a cadence of 60 rpm.

If I compare it with my case I would say: If you use a road bike setup and NOT a rather small gear (of those you got), then this doesn’t look normal to me. If, however, you are riding let’s say with the right half of your available gears on your cassette (again road bike gearing, e.g shimano 105, ultegra, …) or on the large chain ring, than this could be reasonable (as long power readings are consistent).

Hi, did you get to the bottom of this? I’ve just started using a new Flux S on Sufferfest after a couple of years on an Elite trainer. Currently having a lot of issues with power on the Flux, it’s all over the place.

You’ve definitely not allowed the flux S to connect to anything else?
I have this if I let the flux context to my phone or watch, eg for a spin down/ calibration

When that happens I have to search of and on again.

The other one is to start in small ring front and 3rd down at back. Anything else and the manageable range of control of the trainer can’t cope. That ratio gets me from recoveries through to upper MAP , then I need to change great to get into AC & NM

I just tried using ant+ instead of Bluetooth, and that was much better, so it’s definitely a Bluetooth issue for me. Not ideal because I wanted to stop needing an ant+ dongle, but it works at least.

Are you on Windows or IOs?

I’ve sorted my Flux S on Windows. Open up the Tacx app on your phone and connect to thr Flucx, go into settings and turn OFF ant+. Close the Tacx app completely.
Fire up SYSTM. And connect to the Tacx via bluetooth. Has solved all my problems. Sing out if you need help getting to the Tacx ant setting.
And also make sure nothing else is talking to your Tacx.

If you’re on IOs I can’t help unfortunately, I know this doesn’t work for my buddy on IOS.

Thanks, but I’m on a Mac. I tried switching off the ant+ profile on the Tacx app, but it didn’t help. It keeps telling me there’s an update to the app, but never installing it, so maybe there’s a fix on the way.

1 Like