Tacx Vortex not detected by WahooSystm?

Hi guys!

I discovered cycling this summer and ended up going out for a ride on an almost daily basis. Now that it’s getting colder i decided to continue, inside. Since I’m new to all this, I decided to start “small” and bought a second-hand indoor trainer, the TacX Vortex.

I tried setting up everything today, but it looks like my WahooSystm App won’t detect the Trainer. ANT+ (I own a dongle) and Bluetooth are toggled to ON in the App, they both detect my Polar Heartrate Belt, Speed and Cadence sensors that I own, etc. Just not the trainer, which is plugged in (green light blinking as supposed to) :frowning:
Anyone had the same issue with a trainer and found a way to solve this? Maybe I’m missing something?

Thanks in advance for any help :smiley:

1 Like

Hey @Laura_Nicolini welcome to the forums. Love the logo! :woman_superhero:

Not a Tacx user but I’m assuming it’s the “smart” Vortex right?

What app are you using? iphone .iPad , Android, Windows, MacIntel or Mac M1?

Regardless of the above, it may be that something else is “grabbing” the Bluetooth connection and not letting the app do its thing. If you’re using a desktop app, you may need to, at least temporarily, disable Bluetooth on your phone or other devices that may be nabbing the Tacx Bluetooth connection.

I’m not sure why it wouldn’t pick up the Ant+ though you may need an extension cord for the dongle to bring it closer to the trainer. I needed to do that.

Edit: I’m assuming you’ve tapped Add New Device?

Hi Glen!
Thanks a lot for your answer :smiley:

Yes, it’s supposed to be the “smart” Vortex → HOME TRAINER I-VORTEX T2170 TACX. Unless I’m an idiot and missunderstood all.
I tried both on my Windows PC and on my MacBook with the desktop App., but nothing.
I also tried turning off the Bluetooth connection on my phone, but nothing again. Even though I think the trainer needs an ANT+ connection (not Bluetooth)
The ANT+ Antenna is the TacX one with a long cable and is standing right next to the trainer as well, so that can’t be it.
And yes, I’ve tapped Add New Device :stuck_out_tongue:

I may just have found the problem. The I-Vortex and the Vortex are seem to be 2 different trainers. So there i have my mistake after all :cry: The I-Vortex isn’t that smart after all, it looks like at least.


Can you snap a photo of your “antennae”

Sorry if I’m being thick but the Ant+ dongle is just a teeny thing that plugs into a USB port. You usually plug the extension cable into an open usb port on your computer/MacBook and the dongle into the USB receptacle on the cord itself

1 Like

So, if the I-Vortex can’t be connected as a smart trainer you can still connect it as a dumb trainer using your speed sensor, cadence sensor and virtual power.

Using Bluetooth here’s an article

Using Ant+ here’s an article

Yes, that’s what I’m gonna do for now :grin:
Thanks a lot for your time and help!

1 Like

Happy to help. So much to love about the app. Unbeatable value imo. There’s tons of support here in the forums so don’t hesitate to ask for assistance should you run into any issues as you go.

1 Like